dongyouzhui1969
2017-04-06 09:37
浏览 119
已采纳

使用crontab执行php脚本不起作用

I'm trying to execute a php script every day to send an automatic email to the clients that have contacted me. To try if it works I'm trying to execute it every minute. I have followed these steps:

  1. whereis php prompts
php: /usr/bin/php /usr/share/php /usr/share/man/man1/php.1.gz

2. Then I make crontab -e and add a line:

* * * * * /usr/bin/php /var/www2/www/centros-sbc.com/public_html/mail/mail_automatico.php &>> /dev/null

Then I wait a minute and nothing happens. Have any idea?

图片转代码服务由CSDN问答提供 功能建议

我正在尝试每天执行一个php脚本,以便向联系我的客户发送自动电子邮件。 尝试它是否有效我试图每分钟执行一次。 我已按照以下步骤操作:

  1. whereis php 提示
      php:/ usr / bin / php / usr / share / php /usr/share/man/man1/php.1.gz
    
    nn

    \ N2。 然后我做 crontab -e 并添加一行:

      * * * * * / usr / bin / php / var /  www2 / www / centros-sbc.com / public_html / mail / mail_automatico.php&>>  / dev / null 
       
     
     

    然后我等一下,没有任何反应。 有什么想法吗?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • duande1986 2017-04-13 11:16
    已采纳

    Finally I succeed by making it more simple:

            • /usr/bin/php /var/www2/www/centros-sbc.com/public_html/mail/mail_automatico.php

    Thanks to all

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • dongyan5239 2017-04-06 09:38

    Every minute is "* * * * *"

    You've done "every hour at one minute past"

    评论
    解决 无用
    打赏 举报
  • doufei1988 2017-04-06 09:44

    Have your tried /usr/bin/php -f /var/www2/www/centros-sbc.com/public_html/mail/mail_automatico.php &>> /dev/null

    -f option is here to execute the file (your file) mail_automatico.php

    评论
    解决 无用
    打赏 举报
  • dongzhijing8202 2017-04-06 15:11

    1) check if your cron job is working (service crond status | systemctl status crond)

    2) &>/dev/null is normally equal to > /dev/null 2>&1. But some shells doesn't support it.

    have you tried > /dev/null 2>&1 instead &>/dev/null ?

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题