douqi3195 2015-04-07 07:21
浏览 83
已采纳

来自GitLab的私有存储库存档(tar.gz),通过GitLab的API使用PHP下载,似乎已被破坏 - 校验和无效

I want to download a private GitLab repository archive using their API. I'm using PHP and cURL to do that. I'm able to do so using the following code:

$ch = curl_init(http://example.com/api/v3/projects/64/repository/archive?private_token=private_token_goes_here);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_setopt($ch, CURLOPT_BINARYTRANSFER, true);

$output = curl_exec($ch);
$fh = fopen("out.tar.gz", 'w');
fwrite($fh, $output);
fclose($fh);

The code itself is nothing complicated and pretty standard.

The issue I'm facing is that once I try to unpack, using the code bellow:

    // decompress from gz
    $p = new PharData($temp_archive . '.tar.gz');
    $p->decompress($temp_archive . '.tar');

    // unarchive from the tar
    $phar = new PharData($temp_archive . '.tar');
    $phar->extractTo($extract_path);

I receive the following error:

Fatal error: Uncaught exception 'UnexpectedValueException' with message ' in phpfile.php on line 294

UnexpectedValueException: phar error: "path/to/downloaded/archive/temp_archive.tar.gz" is a corrupted tar file (checksum mismatch of file "52 comment=01607149cd460cba6f1ac3003bb7b0c9cb0e2b94
") in phpfile.php on line 294

Yes, that is the whole error, I didn't cut out the error message. The ' is the error message.

The checksum for the downloaded file is, indeed, invalid. After a few good hours of Googling and forum browsing I'm back to square one. I have no idea what's wrong with it.

If I was to untar the archive using a terminal(I'm on MAC OS Build 12E55), it will unpack normally. The files are all there and I receive no errors what-so-ever.

I tried manually downloading the archive from GitLab and unpacking it using PHP(I get the same error).

I tried creating a *.tar.gz file using a terminal and unpacking it using PHP(I receive no errors and the unpacking proceeds normally).

I tried uploading a file created using the terminal and downloading it using PHP, after which I unpacked it, again using PHP, and I receive no errors.

I can only assume that I'm either:

  • Not using their API properly
  • Not setting the right headers - although I had tried setting:
    1. Content-Type: application/octet-stream
    2. Content-Type: application/x-tar
    3. Content-Transfer-Encoding: binary...and so on. When using the binary header, the file that I put the content in was set to 'wb'. Still, no luck.

And lastly it could be that their API may not be working properly, although I doubt it.

And nudging in the right direction is greatly appreciated.

  • 写回答

1条回答 默认 最新

  • duanjiaoxi4928 2015-04-07 08:39
    关注

    This appears to be a bug in the PharData class implementation that was fixed only very recently, see https://bugs.php.net/bug.php?id=64343.

    So it seems that Github uses the pax format for tar files, instead of the ustar format. For a description on tar formats, see: https://github.com/libarchive/libarchive/wiki/FormatTar

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥100 读取 IMU BNO080 数据
  • ¥15 基于RTKLIB框架写的精密单点定位-AR
  • ¥15 PFENet的预训练权重
  • ¥15 程序哪有错误怎么改?
  • ¥15 交换机和交换机之间的链路带宽以及主机带宽的理解
  • ¥15 ai创想家对战模式代码
  • ¥15 集合A由3个2行4列二维数组构成,从集合A中任意取一个二维数组元素、如果该二维数组元素的对应列位置的上、下两数都是奇数,而且仅有2个列是奇数/奇数,则该数组有意义,并放入集合B中打印输出。
  • ¥15 电信IPV6 无法外网访问吗
  • ¥15 有偿求效果比较好的遥感影像匹配的c++代码
  • ¥15 博主,你好,我下载了你的智能网联汽车辅助驾驶安全信息检测系统,现在不会运行,可以教我吗,