dongshi4589
2017-08-13 17:17 阅读 136
已采纳

无法在ubuntu 16.10上再次安装php5.6-curl。 ppa被添加。

Im trying to install php5.6-curl package. It was installed before but I did some stuff with manual build of curl, so I had remove php5.6-curl package from system. I also ran apt autoremove after this operation.

So, after successfull build stuff I was trying to call apt-get install php5.6-curl and it showed me this.

dirst@dirst-machine:~$ sudo apt-get install php5.6-curl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package php5.6-curl is not available, but is referred to by another 
package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5.6-curl' has no installation candidate

You can be sure that ppa:ondrej/php5-5.6 is installed on my ubuntu as php5.6 is present in the system and php5.6-curl package had been isntalled before.

I also tried to add ppa again and ran apt-get update. Im not sure what this messages means.

http://ppa.launchpad.net/ondrej/php/ubuntu yakkety InRelease
.....
   Fetched 107 kB in 3s (31.9 kB/s)
Reading package lists... Done
W: The repository 'http://ppa.launchpad.net/shutter/ppa/ubuntu yakkety Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: https://repo.skype.com/deb stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1F3045A5DF7587C3
W: The repository 'https://repo.skype.com/deb stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: https://linuxdesktopcloud.mail.ru/screenshoter/deb/dists/appind/InRelease: Signature by key 8A99BA500079839DF7DE4833196205AF7396FF77 uses weak digest algorithm (SHA1)
E: Failed to fetch http://ppa.launchpad.net/shutter/ppa/ubuntu/dists/yakkety/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Next what I tried is to check php extensions available with apt-cache search php5.6. There is no php5.6-curl but I know it should be there.

dirst@dirst-machine:~$ apt-cache search php5.6
php-igbinary - igbinary PHP serializer
php-msgpack - PHP extension for interfacing with MessagePack
php-ssh2 - Bindings for the libssh2 library
php-xdebug - Xdebug Module for PHP
php5.6-opcache - Zend OpCache module for PHP
php5.6-mysql - MySQL module for PHP
php5.6-json - JSON module for PHP
php5.6-common - documentation, examples and common module for PHP
php5.6 - server-side, HTML-embedded scripting language (metapackage)
php5.6-mcrypt - libmcrypt module for PHP
php5.6-readline - readline module for PHP
php5.6-gd - GD module for PHP
php5.6-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
php5.6-cli - command-line interpreter for the PHP scripting language
php5.6-mbstring - MBSTRING module for PHP
php5.6-ldap - LDAP module for PHP
libapache2-mod-php5.6 - server-side, HTML-embedded scripting language (Apache 2 module)
php-memcached - memcached extension module for PHP, uses libmemcached

I also launched clean ubuntu 16.04 in the cloud and tried to do same actions. - Install php5.6, php5.6-curl. - Remove curl and then build it manually - Install php5.6-curl again

All worked like a charm. And list of the extensions is way too bigger when I execute apt-cache search php5.6 on cloud ubuntu.

I dont't know what am I doing wrong, Im not really strong linux guys, so I have no Idea what is going on. Please help.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

1条回答 默认 最新

  • 已采纳
    douzhanglu4591 douzhanglu4591 2017-08-14 07:08

    guys from askubuntu helped. Thing was obvious. Just change ppa repo to xenial from yakkety and it works. As yakkety doesn't have php5.6-curl in repo.

    点赞 评论 复制链接分享

相关推荐