dongxun8189
dongxun8189
2017-03-31 08:54

如何让Sublime Text 3使用我的$ PATH?

  • shell
  • php

I have a sublime plugin which executes a script that starts with

#!/usr/bin/env php

Now, when I execute this script from a terminal it will use the php I have in my $PATH (installed by phpbrew) but when the sublime plugin executes the script it will use the php binary installed by macOS (Sierra), which is not the same PHP version. (Note that the plugin does not specify which binary to use, it is resolved by #!/usr/bin/env php when executing the script).

How can I make Sublime respect my $PATH settings?

Edit: I changed #!/usr/bin/env php to #!/path/to/my/php/version in the script that was going to be executed and it works as a work-around for now.

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

2条回答