2016-04-21 12:42


  • http-post
  • http-headers
  • php

I am using file_get_contents() to perform a POST to an API service. This is working for most of the queries. However, recently I had a failure in which file_get_contents() returned HTTP headers in the content!

For the code:

$resp = file_get_contents("",false, $context);

I get the following content and headers every time:

string(114328) "Server: Spark Proxy Server
Content-Length: 114272

array(1) {
  string(31) "HTTP/1.0 200 Spark Proxy Server"

Notice that inside the $resp you can see headers (the first two lines) which should normally be parsed in $http_response_header.

I have also tried two different approaches to do the POST: (a) fopen + while loop and (b) fopen + stream_get_contents. In all three cases the results are the same. The common thing between all three is the stream context which I create using:

$opts = array('http' =>
    'method'  => 'POST',
    'header'  => 'Content-type: application/x-www-form-urlencoded;charset=utf-8',
    'content' => http_build_query($params)

$context  = stream_context_create($opts);

Now, querying the same API with the same code but with a single parameter modified, everything works as expected and the complete headers are:

array(3) {
  string(31) "HTTP/1.0 200 Spark Proxy Server"
  string(26) "Server: Spark Proxy Server"
  string(19) "Content-Length: 288"

Finally, I have tried the same call that fails with python and cUrl and in both cases the results are correct, so I am pretty sure it is php related issue.


  • Has anyone seen this behavior before?
  • Is there a way to perform the same POST without using stream_context_create?
  • Can it be time related? The example that fails takes up to 1.4 minutes to complete
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答


  • duancai1904 duancai1904 5年前

    I have tried this again today... and instead of headers mixed in the content, I got empty content and partial headers. This error though is a lot easier to google and lead me to this SO answer talking about a similar problem (weird file_get_contents behavior).

    As the first comment hinted, changing the default socket timeout solves my problem (it was set to 60):

    ini_set("default_socket_timeout", 600);

    I am not quite sure how the socket can timeout since the data and the headers received seemed complete...

    点赞 评论 复制链接分享