普通网友 2016-04-21 12:42
浏览 40
已采纳

file_get_contents返回内容中的HTTP标头

I am using file_get_contents() to perform a POST to an API service. This is working for most of the queries. However, recently I had a failure in which file_get_contents() returned HTTP headers in the content!

For the code:

$resp = file_get_contents("http://10.72.18.21:8000",false, $context);
var_dump($resp);
var_dump($http_response_header);

I get the following content and headers every time:

string(114328) "Server: Spark Proxy Server
Content-Length: 114272

{"records":....}
"
array(1) {
  [0]=>
  string(31) "HTTP/1.0 200 Spark Proxy Server"
}

Notice that inside the $resp you can see headers (the first two lines) which should normally be parsed in $http_response_header.

I have also tried two different approaches to do the POST: (a) fopen + while loop and (b) fopen + stream_get_contents. In all three cases the results are the same. The common thing between all three is the stream context which I create using:

$opts = array('http' =>
array(
    'method'  => 'POST',
    'header'  => 'Content-type: application/x-www-form-urlencoded;charset=utf-8',
    'content' => http_build_query($params)
    )
);

$context  = stream_context_create($opts);

Now, querying the same API with the same code but with a single parameter modified, everything works as expected and the complete headers are:

array(3) {
  [0]=>
  string(31) "HTTP/1.0 200 Spark Proxy Server"
  [1]=>
  string(26) "Server: Spark Proxy Server"
  [2]=>
  string(19) "Content-Length: 288"
}

Finally, I have tried the same call that fails with python and cUrl and in both cases the results are correct, so I am pretty sure it is php related issue.

Questions:

  • Has anyone seen this behavior before?
  • Is there a way to perform the same POST without using stream_context_create?
  • Can it be time related? The example that fails takes up to 1.4 minutes to complete
  • 写回答

1条回答 默认 最新

  • duancai1904 2016-04-22 11:46
    关注

    I have tried this again today... and instead of headers mixed in the content, I got empty content and partial headers. This error though is a lot easier to google and lead me to this SO answer talking about a similar problem (weird file_get_contents behavior).

    As the first comment hinted, changing the default socket timeout solves my problem (it was set to 60):

    ini_set("default_socket_timeout", 600);
    

    I am not quite sure how the socket can timeout since the data and the headers received seemed complete...

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥100 关于注册表摄像头和麦克风的问题
  • ¥30 代码本地运行正常,但是TOMCAT部署时闪退
  • ¥15 关于#python#的问题
  • ¥15 主机可以ping通路由器但是连不上网怎么办
  • ¥15 数据库一张以时间排好序的表中,找出多次相邻的那些行
  • ¥50 关于DynamoRIO处理多线程程序时候的问题
  • ¥15 kubeadm部署k8s出错
  • ¥15 Abaqus打不开cae文件怎么办?
  • ¥20 双系统开机引导中windows系统消失问题?
  • ¥15 小程序准备上线,软件开发公司需要提供哪些资料给甲方