dounei5721
2014-06-06 16:27
浏览 21
已采纳

本地wordpress dev发出index.php和admin工作 - 没有其他页面响应

I am having a severe issues setting up a local dev environment on my mac for a wordpress site i am working on. Below is the process i have tried:

Start apache locally Set up dev environment in httpd.conf files Set up dev name. Set up dev name to link to location of files Set up dev IP. This process worked fore every other instance except this one.

The wp-admin works fine and all posts and updates can be made there. The index.php works fine. However, this is it. No posts are working and they all come back with the same error message: 'The requested URL // was not found on this server’.

*It should be mentioned that I had xampp installed on my machine and it was running out of the same port as my local apache and sql. I changed the ports on xampp and this did not work. I uninstalled xampp, restarted my computer and this did not work.

I have several other virtual environments up and they work just fine – though they are not .php and sql based. I have been looking into this issue for about a day now and cannot figure it out.

图片转代码服务由CSDN问答提供 功能建议

我正在为我正在处理的wordpress网站在我的mac上设置本地开发环境时遇到严重问题。 以下是我尝试过的过程:

在本地启动apache 在httpd.conf文件中设置开发环境 设置开发名称。 设置开发名称以链接到文件位置\ n设置开发IP。 除了这个之外,这个过程优先于其他所有实例。

wp-admin工作正常,所有帖子和更新都可以在那里完成。 index.php运行正常。 但是,就是这样。 没有帖子正在运行,他们都返回了相同的错误消息:'在此服务器上找不到请求的URL //'。

*应该提到我安装了xampp 在我的机器上,它与我的本地apache和sql运行在同一个端口上。 我更改了xampp上的端口,但这不起作用。 我卸载了xampp,重新启动了我的计算机,但这没有用。

我还有其他几个虚拟环境,它们工作正常 - 尽管它们不是.php和基于sql的。 我一直在研究这个问题大约一天,无法弄明白。

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dsbezji539113152 2014-06-06 16:35
    已采纳

    OS X by default disables .htaccess overriding in order to enable it follow these steps:

    Open this file:

    /etc/httpd/users/yourusername.conf
    

    Save with:

    <Directory "/Users/yourusername/Sites/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    

    Then restart apache with this command:

    sudo apachectl restart
    
    打赏 评论

相关推荐 更多相似问题