来自localhost的远程MySQL连接Codeigniter =非常慢

I am using Codeigniter & LAMP stack (without the MySQL) on my localhost to connect to a remote MySQL database on my server. This configuration is for development purposes only.

Problem: It takes up to a minute for the entire page to load! Is there any way to make this connection faster?

Sometimes its so slow i even get the error:

A Database Error Occurred

Unable to select the specified database: x

Filename: /Applications/MAMP/htdocs/x/third_party/MX/Loader.php

Line Number: 96
douyicao2199
douyicao2199 我在世界各地使用住宅电缆。当我和美国服务器在同一个国家/地区时,我注意到远程SQL访问的加载时间较慢,但它并不慢!也许节流解释了为什么它这么慢?
接近 9 年之前 回复
doushi6947
doushi6947 什么样的互联网连接?如果您正在经营T1或其他事情,那么这可能不是问题。但如果您使用住宅电缆或DSL连接,ISP可能会故意限制像3306这样的端口。
接近 9 年之前 回复
duadlkc5762218
duadlkc5762218 仅建立1个连接,并禁用远程数据库上的主机名解析。当然,请确保只查询所需的绝对最小数据量。
接近 9 年之前 回复

2个回答



除非您的应用程序在数据库上非常难,否则反向DNS解析很可能是原因。 通过将 skip-name-resolve </ code>添加到 my.cnf </ code>,在远程服务器上禁用它。</ p>

另请注意,即使对于 简单的查询,“遍布全球”的往返时间可能是200毫秒甚至更多,因此无论数据的复杂程度或数量如何,仅</ em>需要300次查询才能在网络上花费一分钟。</ p >
</ div>

展开原文

原文

Unless your app is very hard on the DB, it is very likely that reverse DNS resolution is the cause. Disable it on the remote server by adding skip-name-resolve to your my.cnf.

Also, note that even for simple queries, the roundtrip "across the world" may be 200 ms or even more, so it only takes 300 queries to spend a minute on networking, regardless of the complexity or amounts of data.

doutuan8887
doutuan8887 那么,您是否尝试过禁用DNS查找?
接近 9 年之前 回复
dshfjsh_5455
dshfjsh_5455 当前查询数约为5,肯定低于10.需要30-60秒的可变时间才能加载页面。 奇怪...
接近 9 年之前 回复



我收到了同样的错误信息。 问题是我没有正确设置连接参数。 Douoble - 检查database.php中的数据库服务器凭据。 确保主机名,用户名,密码和数据库正确无误。</ p>
</ div>

展开原文

原文

I got the same error message. The problem was that I didn't set the connection parametres correctly. Douoble-check your Database Server credentials in database.php . Make sure the hostname, username, password and database are correct.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问