dty63504
dty63504
2016-03-29 08:34

Go编译的二进制文件不会在Ubuntu主机上的高山Docker容器中运行

已采纳

Given a binary, compiled with Go using GOOS=linux and GOARCH=amd64, deployed to a docker container based on alpine:3.3, the binary will not run if the docker engine host is Ubuntu (15.10):

sh: /bin/artisan: not found

This same binary (compiled for the same OS and arch) will run just fine if the docker engine host is busybox (which is the base for alpine) deployed within a VirtualBox VM on Mac OS X.

This same binary will also run perfectly fine if the container is based on one of Ubuntu images.

Any idea what this binary is missing?

This is what I've done to reproduce (successful run in VirtualBox/busybox on OS X not shown):

Build (building explicitly with flags even though the arch matches):

➜  artisan git:(master) ✗ GOOS=linux GOARCH=amd64 go build

Check it can run on the host:

➜  artisan git:(master) ✗ ./artisan 
10:14:04.925 [ERROR] artisan: need a command, one of server, provision or build 

Copy to docker dir, build, run:

➜  artisan git:(master) ✗ cp artisan docker/build/bin/        
➜  artisan git:(master) ✗ cd docker 
➜  docker git:(master) ✗ cat Dockerfile 
FROM docker:1.10
COPY build/ /
➜  docker git:(master) ✗ docker build -t artisan .
Sending build context to Docker daemon 10.15 MB
Step 1 : FROM docker:1.10
...
➜  docker git:(master) ✗ docker run -it artisan sh
/ # /bin/artisan 
sh: /bin/artisan: not found

Now changing the image base to phusion/baseimage:

➜  docker git:(master) ✗ cat Dockerfile 
#FROM docker:1.10
FROM phusion/baseimage
COPY build/ /
➜  docker git:(master) ✗ docker build -t artisan .
Sending build context to Docker daemon 10.15 MB
Step 1 : FROM phusion/baseimage
...
➜  docker git:(master) ✗ docker run -it artisan sh
# /bin/artisan
08:16:39.424 [ERROR] artisan: need a command, one of server, provision or build 
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

3条回答

  • dongxiao0449 dongxiao0449 5年前

    By default, if using the net package a build will likely produce a binary with some dynamic linking, e.g. to libc. You can inspect dynamically vs. statically link by viewing the result of ldd output.bin

    There are two solutions I've come across:

    • Disable CGO, via CGO_ENABLED=0
    • Force the use of the Go implementation of net dependencies, netgo via go build -tags netgo -a -v, this is implemented for a certain platforms

    From https://golang.org/doc/go1.2:

    The net package requires cgo by default because the host operating system must in general mediate network call setup. On some systems, though, it is possible to use the network without cgo, and useful to do so, for instance to avoid dynamic linking. The new build tag netgo (off by default) allows the construction of a net package in pure Go on those systems where it is possible.

    The above assumes that the only CGO dependency is the standard library's net package.

    点赞 评论 复制链接分享
  • doushang2021 doushang2021 4年前

    Go compiler from your build machine probably links your binary with libraries on different location than in Alpine. In my case it was compiled with dependencies under /lib64 but Alpine does not use that folder.

    FROM alpine:edge AS build
    RUN apk update
    RUN apk upgrade
    RUN apk add --update go=1.8.3-r0 gcc=6.3.0-r4 g++=6.3.0-r4
    WORKDIR /app
    ENV GOPATH /app
    ADD src /app/src
    RUN go get server # server is name of our application
    RUN CGO_ENABLED=1 GOOS=linux go install -a server
    
    FROM alpine:edge
    WORKDIR /app
    RUN cd /app
    COPY --from=build /app/bin/server /app/bin/server
    CMD ["bin/server"]
    

    I'm working on article about this issue. You can find draft with this solution here http://kefblog.com/2017-07-04/Golang-ang-docker .

    点赞 评论 复制链接分享
  • dongshiran7000 dongshiran7000 3年前

    I had the same issue with a go binary, and I got it to work after adding this to my docker file:

    RUN apk add --no-cache \ libc6-compat

    点赞 评论 复制链接分享