ubuntu10.04如何安装rpm安装包? 10C

公司开发人员给了一个rpm的安装包,让我在ubuntu的系统下安装测试,
但是我使用rpm -ivh --debian xxx.rpm的命令进行安装时,就会弹出libc.so.6等被xxx.rpm所需要的提示
我已经安装了rpm,glibc等相关到安装包了,请问要怎么解决这些依赖关系?
不知道为什么不能上传图片,具体到错误如下:
libc.so.6被xxx.rpm所需要
libc.so.6(GLIBC_2.0)被xxx.rpm所需要
libc.so.6(GLIBC_2.1)被xxx.rpm所需要
libc.so.6(GLIBC_2.1.3)被xxx.rpm所需要
libc.so.6(GLIBC_2.3)被xxx.rpm所需要
libc.so.6(GLIBC_2.8)被xxx.rpm所需要
libdl.so.2被xxx.rpm所需要
libdl.so.2(GLIBC_2.0)被xxx.rpm所需要
libdl.so.2(GLIBC_2.1)被xxx.rpm所需要
libm.so.6被xxx.rpm所需要
libm.so.6(GLIBC_2.0)被xxx.rpm所需要
libpthread.so.0被xxx.rpm所需要
libpthread.so.0(GLIBC_2.0)被xxx.rpm所需要
libpthread.so.0(GLIBC_2.1)被xxx.rpm所需要
libpthread.so.0(GLIBC_2.3.2)被xxx.rpm所需要
librt.so.1被xxx.rpm所需要
librt.so.1(GLIBC_2.2)被xxx.rpm所需要
rtld(GNU_HASH)被xxx.rpm所需要

3个回答

这是说你要安装的程序需要用那些包,你得把它所有依赖的包都安装了。

这是缺少依赖库啊,依赖的一些库没有安装。

libc.so.6被xxx.rpm所需要
libc.so.6(GLIBC_2.0)被xxx.rpm所需要
libc.so.6(GLIBC_2.1)被xxx.rpm所需要
libc.so.6(GLIBC_2.1.3)被xxx.rpm所需要
libc.so.6(GLIBC_2.3)被xxx.rpm所需要
libc.so.6(GLIBC_2.8)被xxx.rpm所需要
libdl.so.2被xxx.rpm所需要
libdl.so.2(GLIBC_2.0)被xxx.rpm所需要
libdl.so.2(GLIBC_2.1)被xxx.rpm所需要
libm.so.6被xxx.rpm所需要
libm.so.6(GLIBC_2.0)被xxx.rpm所需要
libpthread.so.0被xxx.rpm所需要
libpthread.so.0(GLIBC_2.0)被xxx.rpm所需要
libpthread.so.0(GLIBC_2.1)被xxx.rpm所需要
libpthread.so.0(GLIBC_2.3.2)被xxx.rpm所需要
librt.so.1被xxx.rpm所需要
librt.so.1(GLIBC_2.2)被xxx.rpm所需要
rtld(GNU_HASH)被xxx.rpm所需要

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问