2 chinapaladin chinapaladin 于 2016.04.28 14:35 提问

升级struts2 2.3.16 报错 BeanCreationException

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'treeMenuDao' defined in ServletContext resource [/WEB-INF/dataAccessContext-local.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [com.sunyard.zj.dao.ibatis.TreeMenuDaoImpl]: Constructor threw exception; nested exception is java.lang.NullPointerException
Caused by: org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [com.sunyard.zj.dao.ibatis.TreeMenuDaoImpl]: Constructor threw exception; nested exception is java.lang.NullPointerException
Caused by: java.lang.NullPointerException

原来用的struts2 2.0.11 版本 最近说有漏洞要升级,结果升级了就报错,用的strunts+spring+ibatis. 网上找了好多解决办法都是对于hibernate的。求大神帮忙。

3个回答

CSDNXIAOD
CSDNXIAOD   2016.04.28 14:42

struts2 2.3.15升级到2.3.16问题
----------------------biu~biu~biu~~~在下问答机器人小D,这是我依靠自己的聪明才智给出的答案,如果不正确,你来咬我啊!

chinapaladin
chinapaladin 不好用哎。。。安上面说的,改了还是不行
大约 2 年之前 回复
chinapaladin
chinapaladin   2016.04.28 15:09

自己顶!d=====( ̄▽ ̄*)b

a666sh
a666sh   2016.07.02 14:32

错误上不是写了吗?在配置中找不到那个名字的dao

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Struts2高位漏洞升级到struts2.3.32
Struts2高位漏洞升级到struts2.3.323月7日带来了一个高危漏洞Struts2漏洞——CVE编号CVE-2017-5638。其原因是由于Apache Struts2的Jakarta Multipart parser插件存在远程代码执行漏洞,攻击者可以在使用该插件上传文件时,修改HTTP请求头中的Content-Type值来触发该漏洞,导致远程执行代码。 升级jar包 更新这些jar包
struts2.3.16之环境搭建
1、首先先在网上下载struts2.3.16的完整版,里面有几个文件夹,分别为:apps——范例代码,docs——api,lib——类库,src——源码     2、在myeclipse中新建一个java web project,名称为sshTest     3、添加所需要的类包,在WebContent/WEB-INF/lib目录下,以下为必需的类包          4、接下来就是编写s
struts2 版本升级2.3.16.3解决多个前缀参数远程命令行漏洞 josn
Apache Struts2在处理action、redirect、和redirectAction前缀参数时存在一个安全漏洞,攻击者可以通过提交带有恶意的Ongl表达式,远程执行任意命令。 在2.3以下的
升级Struts2 2.3.15.1升级到2.3.32
由于struts2漏洞升级  原来升级到2.3..28.1 文件记载的很多东西都已丢失,最近内网的一个服务器需要公布到外网上,正好又遇到了 S2-045漏洞。以前记载的东西都已丢失。 所以在网上开记载。同时和大家分享。 升级到 2.3..28.1基本替换的架包 xwork-core-2.3.28.1.jar ;struts2-json-plugin-2.3.28.1.jar;
struts2.3.15升级到2.5.13
struts2.3.15升级到2.5.13 1、下载jar包struts2.5.13所有的jar包从官网下载的https://struts.apache.org/index.html 最新的jar包https://struts.apache.org/download.cgi#struts2513 [struts-2.5.13-all-zip[PGP][MD5]] 2、替换项目中所
struts2 升级至2.3.32
背景: struts2近日被曝存在远程代码执行的严重漏洞。目前Struts2官方已经确认漏洞 (漏洞编号S2-045,CVE编号:cve-2017-5638),并定级为高危。 由于该漏洞影响范围极广(Struts2.3.5 - Struts 2.3.31, Struts 2.5 - Struts 2.5.10), 漏洞危害程度极为严重,可直接获取应用系统所在服务器的控制权限。 如果你
struts框架-2.3.16.3
struts是开源软件。使用Struts的目的是为了帮助我们减少在运用MVC设计模型来开发Web应用的时间。
Struts2 2.3.32升级到2.3.34
近期Struts官方不断发布漏洞,因为工作的原因,我这里的项目也必须升级到2.3.34,我这里是从2.3.32开始升级(话说几天前我才从2.3.30升上去。。)。而且不能升级到2.5.13的大版本,改动比较麻烦。然后我在网络上找相关的升级方案,可惜漏洞发布没多久,还没有相关的详细解决方案。于是结合一些前辈的资料摸索出了一套方案。下面给出我收集来的jar包的下载地址: 稍后给出。。
Struts2 jar包下载struts2.3.16
commons-fileupload-1.2.1.jar//文件上传时用的,为了以后用到,最好加入 commons-io-1.3.2.jar//同上 commons-logging-1.0.4.jar freemarker-2.3.16.jar javassist-3.7.ga.jar ognl-3.0.jar struts2-core-2.2.1.1.jar xwork-core-2.2.1.1.jar 共8个包,将其复制到/Struts2/WebRoot/WEB-INF/lib下面
启动tomcat,出现BeanCreationException以及NUllPointerException
信誓旦旦决定在CSDN上写bolg记录自己平时遇到的bug,结果那天之后居然就没再写过了,正好最近遇到个特别头疼的bug,就趁着中秋放假,把它记录下来吧。 问题描述:前一天还运行正常的一个maven项目,第二天启动的时候出现了如下错误: 控制台打印信息如下: Caused by: org.springframework.beans.factory.BeanCreationException: