ubuntu调用import matplotlib.pyplot as plt报错 2C

鄙人安装了numpy,scipy,最后安装的matplotlib,安装完成后导入:import matplot无报错,但是import matplotlib.pyplot as plt则出现了如下错误:

This application failed to start because it could not find or load the "
in "".
Reinstalling the application may fix this problem.

已放弃 (核心已转储)

我通过重新配置了依赖项和pyQt4依旧没有解决,求大神支招。感激不尽

2个回答

直接python命令行中输入试试。

您好,我也遇到了您的这个问题,我先描述一下我的问题:我的是Ubuntu16.04版本的,刚开始系统默认安装的是python2.7,我直接用pip安装的matplotlib,导入可以使用,但是由于我需要使用python3.6,所以我将默认版本修改成python3.6,但是这样就会出现一些列关于matplotlib的问题,我也看到了网上的很多方法,都试过了但是不管用,最后我尝试安装anaconda3,然后通过anaconda3来安装matplotlib,安装成功后,我再次打开python,输入import matplotlib.pyplot as plt,成功了。如图所示:
图片说明

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问