sudo apt-get install linux-source的问题 5C

之前同步过一次源码,手动删除后再次执行命令就下载不下来了?
再执行 apt-get install linux-source 的话提示
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
linux-source 已经是最新的版本。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 17 个软件包未被升级。

dpkg -L linux-source-3.13.0
/.
/usr
/usr/src
/usr/src/linux-source-3.13.0
/usr/src/linux-source-3.13.0/linux-source-3.13.0.tar.bz2
/usr/src/linux-source-3.13.0/debian
/usr/src/linux-source-3.13.0/debian/commit-templates
/usr/src/linux-source-3.13.0/debian/commit-templates/config-updates
/usr/src/linux-source-3.13.0/debian/commit-templates/missing-modules
/usr/src/linux-source-3.13.0/debian/commit-templates/sauce-patch
使用命令查找可以显示目标位置
但是实际上用ls查看并没有显示文件 cd也提示没有目录
/usr/src/还是没有文件

有人说是虚包,并不是很懂,该如何解决

4个回答

你是没有删除干净,你可以-ls查看是否有残留,或者使用grep命令查找以前的文件是否有残留,全部删除后再重新执行apt-get install linux-source应该会好
,如果实在不行,建议不要浪费时间,再建立个虚拟机也行。

换个source看看,用阿里的或者163

你可以换个清华源或者阿里源

建议尝试使用apt-get remove linux-source来移除,然后在重新install

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
sudo apt-get install vim-gtk
Ubuntu 中sudo apt-get install vim-gtk 是啥意思??
sudo apt-get install vim
tar:无法识别的选项“--warning=no-timestamp”rn请尝试执行 “tar --help” 或 “tar --usage”rn来获取更多信息。rndpkg-deb: error: 子进程 tar 返回了错误号 64rndpkg:处理 /var/cache/apt/archives/vim-common_2%3a7.3.429-2ubuntu2.1_amd64.deb (--unpack)时出错:rn 子进程 dpkg-deb --control 返回了错误号 2rnrnrnwho know how to fix this problem?
sudo apt-get update问题
我用的是ubuntu10.10的系统,添加的是163的源,源如下:rndeb http://mirrors.163.com/ubuntu/ maverick main universe restricted multiverserndeb-src http://mirrors.163.com/ubuntu/ maverick main universe restricted multiverserndeb http://mirrors.163.com/ubuntu/ maverick-security universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-security universe main multiverse restrictedrndeb http://mirrors.163.com/ubuntu/ maverick-updates universe main multiverse restrictedrndeb http://mirrors.163.com/ubuntu/ maverick-proposed universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-proposed universe main multiverse restrictedrndeb http://mirrors.163.com/ubuntu/ maverick-backports universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-backports universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-updates universe main multiverse restrictedrn在linux下可以打开上面的网站,但打sudo apt-get update时老是报407的错误,错误如下rnW: Failed to fetch http://mirrors.163.com/ubuntu/dists/maverick-backports/multiverse/binary-amd64/Packages.gz 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )rn我应该怎么做才能让update可以更新,求高手告知!!!!
apt-get install 问题请教
1 用apt-get install xxx 后装好的xxx软件是放在哪个目录下的?rn 2 是不是这样只安装了这个软件 放在bin目录下 那儿如果想把这个软件的deb安装rn包也保存下来 下次不用再通过网上去下 该怎么办呢?rn 谢谢!
apt-get install libgl1-mesa-dev问题
执行如下的命令,产生后面的错误信息:rnrnluoqs@HakkaUbuntu:~$ sudo apt-get install libgl1-mesa-devrnrn下列软件包有未满足的依赖关系:rn libgl1-mesa-dev: 依赖: libgl1-mesa-glx (= 7.7.1-1ubuntu2) 但是 7.7.1-1ubuntu3 正要被安装rnE: 破损的软件包rnrnrn上面问题怎么解决????
sudo apt-get update时的问题
提供sudo apt-get update时出现问题的解决方案!
sudo apt-get常用命令
下面总结一下有关apt-get的常用但容易混淆的指令: 一、卸载 1. sudo apt-get autoclean: 如果你的硬盘空间不大的话,可以定期运行这个程序,将已经删除了的软件包的.deb安装文件从硬盘中删除掉。如果你仍然需要硬盘空间的话,可以试试apt-get clean,这会把你已安装的软件包的安装包也删除掉,当然多数情况下这些包没什么用了,因此这是个为硬盘腾地方的好办法...
apt-get install 遇到依赖问题
sudo apt-get install aptitude Problem & Solution:找不到aptitude包, 则先sudo apt-get update 之后就可以 sudo aptitude install ...
解决 apt-get install 依赖问题
前面我为了解决ros rviz 仿真启动 Segmentation fault 的问题,安装了自己下载的 libpcre3 版本,结果 导致 我的ubuntu安装管理器 爆炸了,不管是安装还是卸载 都会报 软件包的 依赖问题,如下:E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held
Debian关于apt-get install的问题
我知道Debian和Ubuntu一样,可以通过apt-get工具通过网络远程安装软件。rn因为我现在的Debian系统相通过Gprs无线上网,所以需要安装wvdial和ppp拨号工具(真不知道为啥Debian为啥这么笨,Ubuntu和fedora都带有wvdial和ppp的,愤怒。。)rnrn我的终端的输入输出如下:rndebian@debian:~$ sudo apt-get install wvdialrnReading package lists... DonernBuilding dependency tree rnReading state information... Donernwvdial is already the newest version.rnYou might want to run `apt-get -f install' to correct these:rnThe following packages have unmet dependencies:rn [color=#FF0000]libpcap0.8-dbg: Depends: libpcap0.8 (= 0.9.8-5) but it is not going to be installedrn libpcap0.8-dev: Depends: libpcap0.8 (= 0.9.8-5) but it is not going to be installedrn Depends: libc6-dev but it is not going to be installed[/color]rn ppp: Depends: libpcap0.8 (>= 0.9.3-1) but it is not going to be installedrnE: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).rnrnapt-get不是可以智能自动到网络上寻找资源的吗,怎么不能自动安装关联的软件呢。rnrnyexinzhong@debian:~$ sudo apt-get install ppprn也会出现类似的问题,相关联的软件包不安装,wvidal和ppp还是不能正常使用,求救。。。。rnrnrn
sudo apt-get install gnome-devel 说无法找到软件包
是虚拟机装的ubuntu7.1,用sudo apt-get install gnome-devel 说无法找到软件包,是命令错了吗,还是要怎么配置一下啊
sudo apt-get install app 后程序装在哪个目录下面了?
最近要作NS2仿真,图省事就用sudo apt-get install ns2安装了ns2,但是现在要修改ns的很多程序,却找不到ns在哪个目录。rn
sudo apt-get install 时意外中断,导致资源加锁
cd /var/lib/apt/lists sudo rm -rf * sudo rm -rf /var/cache/apt/archives/lock sudo rm -rf /var/lib/dpkg/lock
ubuntu 运行 sudo apt-get install *** 失败,无法安装软件
rnubuntu 运行 sudo apt-get install *** 失败,无法安装软件,提示如下:rnrn(正在读取数据库 ... 50%dpkg: 无法恢复的致命错误,中止:rn 软件包 poppler-data 的文件名列表文件最后结尾的换行符rnE: Sub-process /usr/bin/dpkg returned an error code (2)rnaisq@aisq-VirtualBox:~$ rnrnrn这个是啥问题啊
ubuntu 10.10下sudo apt-get install gnuplot 怎么装不上?
如题,装着会提示无法解析域名,有什么解决的办法吗?可以上网的
sudo apt-get install lib32z1-dev为什么安装不了了!!!
sudo apt-get install lib32z1-dev为什么安装不了了!!!rn32位的ubuntu10.04rn是不是被其他资源代替了,资源的名字换了???rn换成什么了????rnrnrnandroid编译错误,网上找了一下解决方法rn说是要rnapt-get install lib32z1-devrnrn但是提示说木有这个资源呀!!!!!
使用 sudo apt-get install xxx 安装库时报错解决办法
错误如下: fatpuffer@ubuntu:~$ sudo apt install net-tools Reading package lists... Error! E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/dpkg/status E: The package list...
Ubuntu安装软件sudo apt-get install时出现错误
通过终端安装程序sudo apt-get install xxx时出错
Linux:执行sudo apt-get install提示“现在没有可用的软件包
问题描述:sudo apt-get install openssh-server正在读取软件包列表…完成正在分析软件包的依赖关系树Reading state information… 完成现在没有可用的软件包 openssh-server,但是它被其它的软件包引用了。分析:这可能意味着这个缺失的软件包可能已被废弃,或者只能在其他发布源中找到: 软件包 openssh-server 还没有可供安装的候
apt-get install 的用法
ubuntu的apt-get install 的用法详细介绍
apt-get install gcc
我的目的:是想在linux机器安装mailman,但是发现在./configure时,distutils模块有问题,由于该模块是python内置模块,我打算升级python来解决(从2.7.3升级到3.3.1),升级时需要有gcc。rnrn我在阿里云主机执行如下命令(apt-get install gcc)时,报错rnroot@AY1406091621321640dbZ:/usr/local/python3/Python-3.3.0# clearrnroot@AY1406091621321640dbZ:/usr/local/python3/Python-3.3.0# apt-get install gccrnReading package lists... DonernBuilding dependency tree rnReading state information... DonernThe following extra packages will be installed:rn binutils cpp cpp-4.6 gcc-4.6 libc-bin libc-dev-bin libc6 libc6-dev libgmp10 libgomp1 libmpc2 libmpfr4 libquadmath0 linux-libc-dev manpages-devrnSuggested packages:rn binutils-doc cpp-doc gcc-4.6-locales gcc-multilib autoconf automake1.9 libtool flex bison gdb gcc-doc gcc-4.6-multilib libmudflap0-4.6-dev gcc-4.6-doc libgcc1-dbg libgomp1-dbgrn libquadmath0-dbg libmudflap0-dbg binutils-gold glibc-docrnThe following NEW packages will be installed:rn binutils cpp cpp-4.6 gcc gcc-4.6 libc-dev-bin libc6-dev libgmp10 libgomp1 libmpc2 libmpfr4 libquadmath0 linux-libc-dev manpages-devrnThe following packages will be upgraded:rn libc-bin libc6rn2 upgraded, 14 newly installed, 0 to remove and 104 not upgraded.rnNeed to get 9,722 kB/27.1 MB of archives.rnAfter this operation, 55.5 MB of additional disk space will be used.rnDo you want to continue [Y/n]? yrnErr http://cn.archive.ubuntu.com/ubuntu/ precise-updates/main libc-bin amd64 2.15-0ubuntu10.4rn 404 Not FoundrnErr http://cn.archive.ubuntu.com/ubuntu/ precise-updates/main libc6 amd64 2.15-0ubuntu10.4rn 404 Not FoundrnErr http://cn.archive.ubuntu.com/ubuntu/ precise-updates/main libc-dev-bin amd64 2.15-0ubuntu10.4rn 404 Not FoundrnErr http://cn.archive.ubuntu.com/ubuntu/ precise-updates/main libc6-dev amd64 2.15-0ubuntu10.4rn 404 Not FoundrnErr http://cn.archive.ubuntu.com/ubuntu/ precise-updates/main linux-libc-dev amd64 3.2.0-51.77rn 404 Not FoundrnErr http://cn.archive.ubuntu.com/ubuntu/ precise-proposed/main linux-libc-dev amd64 3.2.0-51.77rn 404 Not FoundrnFailed to fetch http://cn.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc-bin_2.15-0ubuntu10.4_amd64.deb 404 Not FoundrnFailed to fetch http://cn.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6_2.15-0ubuntu10.4_amd64.deb 404 Not FoundrnFailed to fetch http://cn.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc-dev-bin_2.15-0ubuntu10.4_amd64.deb 404 Not FoundrnFailed to fetch http://cn.archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_3.2.0-51.77_amd64.deb 404 Not FoundrnFailed to fetch http://cn.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6-dev_2.15-0ubuntu10.4_amd64.deb 404 Not FoundrnE: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?rnrn报找不到文件,比如对于libc-bin_2.15-0ubuntu10.4_amd64.deb没有,但是有libc-bin_2.15-0ubuntu10.5_amd64.deb。rn请问有什么办法可以解决?
apt-get install 出错解决方案
apt-get install 出错:dpkg: syntax error: unknown user `' instatoverride 将 /var/lib/dpkg/statoverride文件内容改为:注意不要有空行 root postdrop 02555 /usr/sbin/postqueuehplip root 755 /var/run/hpliproot postdrop ...
sudo apt-get 停留在0%的解决办法
报错信息如下:0% [正在连接 us.archive.ubuntu.com (2001:67c:1562::19)]0% [Connecting to us.archive.ubuntu.com (2001:67c:1562::14)] - Install not happening解决办法:sudo nano /etc/gai.conf找到#precedence ::ffff:0:0/96  1...
sudo apt-get 正在等待报头
    *文档参考多个网址说明编写,有理解不对指出,欢迎指正。文档尽量给出中文错误信息和操作界面,Eg.缩写表示对应的英文便于阅读。1 apt-get install 出现“正在等待报头”(Eg. waiting for headers)        鉴于标题的长度问题,如果出现“正在连接”(Eg. Connecting to security...)的问题也可以尝试下面的解决方案。1.1 意外...
sudo apt-get update连接失败问题解决
在安装python-pip时出现连接失败错误 进而在执行sudo apt-get update是也出现连接失败错误,怀疑是源不可用: 搜索得知如下解决方案: 1. 先关闭所有源 2. rm -rf /var/lib/apt/lists/*删除/var/lib/apt/lists 所有文件 3. 修改/etc/apt/source.list文件。将源改成163的或者阿里的: (
sudo apt-get update时遇到以下问题
问题: sudo apt-get update时遇到以下问题 W: 以下 ID 的密钥没有可用的公钥: 1397BC53640DB551 W: GPG 错误:http://archive.ubuntukylin.com:10006 xenial InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 8D5A09DC9B929006 W: 无法下载 http:
【虚拟机/服务器】apt-get install 和 pip install的区别
pip install apt-get install 源是pyPI 源是ubuntu仓库 对于同一个包,pyPI可以提供更多的版本以供下载 pip install安装的python包,可以只安装在当前工程内 apt-get 安装的包是系统化的包,在系统内完全安装
解决sudo apt-get update无法更新的问题
一、 参考链接 http://blog.sina.com.cn/s/blog_b953bc190102xe3j.html
apt-get install命令出错解决
apt-get install命令出错解决问题描述问题分析解决办法 问题描述 在用 ubuntu 18.04 安装angr二进制分析框架时,按照Install Instructions的如下命令安装时 sudo apt-get install python3-dev libffi-dev build-essential virtualenvwrapper 安装失败,并提示如下错误信息 Do yo...
“apt-get -f install” 错误与解决方法
​ apt-get -f install = apt-get install -f ,是修复依赖关系(depends)的命令,就是假如你的系统上有某个package不满足依赖条件,这个命令就会自动修复,安装那个package依赖的package。 ​ 1、sudo命令:sudo命令用来以其他身份来执行命令,预设的身份为root,简单来说就是提升权限,因为apt-get ins...
### 高分求教:ubuntu下apt-get install问题 ###
刚装了ubuntu10.10,发现里面没有安装常用的工具,如ftp,svn.于是baidu一下发现有命令可以安装,但是都出现了以下问题,我已经运行过sudo apt-get upgrade 也没有用,baidu了一下发现不少人也遇到过类似问题,但是似乎没有看到解决方法,请教高手如何解决?谢谢。rnrn1)安装SVNrnrnroot@ubuntu:/opt# sudo apt-get install subversionrnReading package lists... DonernBuilding dependency tree rnReading state information... DonernPackage subversion is not available, but is referred to by another package.rnThis may mean that the package is missing, has been obsoleted, orrnis only available from another sourcernrnE: Package 'subversion' has no installation candidaternrnrn2)安装 ftprnrnroot@ubuntu:/opt# sudo apt-get install vsftpdrnReading package lists... DonernBuilding dependency tree rnReading state information... DonernPackage vsftpd is not available, but is referred to by another package.rnThis may mean that the package is missing, has been obsoleted, orrnis only available from another sourcernrnE: Package 'vsftpd' has no installation candidaternrn
解决apt-get install出现依赖包的问题
如果出现依赖包不能自动安装的时候,一般是/etc/apt/sources.list源出现了问题,此时只要将该文件中的源更换即可,源一定要更换为安装系统时配套的源,其他的源或多或少都会有问题。
apt-get install无法安装任意包问题
apt-get install无法安装任意包问题由于在Linux环境中处理linux-image-*包时安装或配置存在问题,导致dpkg不能正常工作,直接结果是apt-get update, apt-get install等都不能正常使用。
解决执行命令 apt-get install 时的依赖问题
Linux系统下加载或安装软件出现以下错误提示: 如果你再次执行命令apt-get update时出现如下错误提示: 解决方法: 可以执行以下命令将目录下/var/lib/apt/lists/partial/的所有的文件清掉: sudo rm /var/lib/apt/lists/* -vf 然后执行以下命令可以清除下载出错的文件夹,如清除 /var/www/目录下的所有文件夹...
sudo gem install bundler 报错
我在mac pro下运行 sudo gem install bundler之后报错rnrn[b]ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)rn Errno::ECONNRESET: Connection reset by peer - connect(2) (https://api.rubygems.org/quick/Marshal.4.8/bundler-1.10.6.gemspec.rz)[/b]rnrn有没有哪个牛人可以帮忙看看为什么的?rnrnruby -vrnruby 2.0.0p481 (2014-05-08 revision 45883) [universal.x86_64-darwin14]rnrngem -vrn2.4.8rnrnrn有没有其他人遇到过这个问题?rnrn谢谢 我分不多 都拿出来了
sudo make install(新手求解)
我添加个简单的系统调用后編译内核rnsudo make install之后 出现下面 语句,我要 重启后用这个新内核还要修改什么吗 rnsh /usr/src/linux-2.6.27.45/arch/x86/boot/install.sh 2.6.27.45 arch/x86/boot/bzImage System.map "/boot"rn
sudo apt-get update执行失败问题解决
错误 在执行sudo apt-get update命令时,执行结果失败,错误信息如下: 获取:1 http://repo.mysql.com trusty InRelease [33.5 kB] 100% [1 InRelease gpgv 33.5 kB] [正在等待报头] [正在等待报头] [正�Couldn't create tempfiles for splitting up /var/l...
ubuntu9.04用sudo apt-get安装出错
今天重装了一下系统,把系统都更新了,但在最后我装完一个curses包后,我再装virtualbox时出现了错误,rn用sudo装软件也出错;rn错误是这样:rnrn#在处理时有错误发生:rn# zephyr-clientsrn#E: Sub-process /usr/bin/dpkg returned an error code (1)rnrnzephyr-clients是一个什么文件?不知道是否有人碰到这样的问题,望给予帮助!rn我的系统是Ubuntu9.04的。
执行sudo apt-get 报错command not found
在网上看到一篇关于Linux有趣命令的文章,看到这么可爱的画面就迫不及待试了一下。。结果一试就报错了。心好累。。(T_T)~~~错误信息是:sudo :apt-get:command not foundn求大神帮解决一下~~是我用的centos不支持这个命令吗,可是怎么解决才能输出这个小火车图案呀~~~~^_^[img=https://img-bbs.csdn.net/upload/201610/13/1476373250_698864.png][/img]
重装Ubuntu 14.04后使用apt-get安装build-essential(即sudo apt-get install build-essential)时出现包依赖项问题的解决方法
重装Ubuntu 14.04后使用apt-get安装build-essential(即sudo apt-get install build-essential)时出现包依赖项问题的解决方法
相关热词 c++和c#哪个就业率高 c# 批量动态创建控件 c# 模块和程序集的区别 c# gmap 截图 c# 验证码图片生成类 c# 再次尝试 连接失败 c#开发编写规范 c# 压缩图片好麻烦 c#计算数组中的平均值 c#获取路由参数