VS2010+openCV2环境搭建好后测试时出现的问题

目前我在64位的win7电脑安装了Visual Studio 2010版本和openCV2.4.9,
安装过程以及相关配置都是按这个教程来的(没有说这个教程不好)
https://blog.csdn.net/bestgonghuibin/article/details/38409613
安装搭建环境都没有出现问题,但是最后在测试的时候,编译没有问题
显示生成文件,但是调试的时候就出现如下错误
图片说明
图片说明
有没有大神知道这个该怎么修改?已经查了很多资料问了一些人但是还没有解决,着急QAQ

6个回答

应该是这个问题,我用x86程序调用x64的库,出了如下问题:
图片说明

phenix2009
白色一大坨 回复sally941205love: 是啊,既然知道原因了,那你把工程换成64的就可以了
一年多之前 回复
sally941205love
sally941205love 对,我的问题应该是和你一样的
一年多之前 回复

test.jpg文件是有的吧?

sally941205love
sally941205love 回复phenix2009: 可以,加你QQ
一年多之前 回复
phenix2009
白色一大坨 回复sally941205love: 我用qq,微信不方便,465617727
一年多之前 回复
sally941205love
sally941205love 加个微信吧,sally941205love
一年多之前 回复
sally941205love
sally941205love 有的
一年多之前 回复

我看你下面x64和x86冲突了,你工程是64位工程吗,如果你配置了64的库,但工程是x86的,库是调用不起来的

sally941205love
sally941205love 回复phenix2009: 我在提问这个问题之前就已经按照这个网页修改过了,修改之后又出现了更多更多各种各样的问题,头都大
一年多之前 回复
sally941205love
sally941205love 那应该怎么搞?能加个微信私聊吗?微信号sally941205love,希望可以帮帮我
一年多之前 回复
phenix2009
白色一大坨 https://blog.csdn.net/ac273317472/article/details/51391951请看一下这篇文档
一年多之前 回复

x86程序和x86_64程序应该是不能直接调用的,你可以写个x64的可执行程序,然后通过x86的exe去调用x64的可执行程序来实现

选择编译平台32或64即可

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
VS2010+openCV2环境搭建好后测试时出现的问题
目前我在64位的win7电脑安装了Visual Studio 2010版本和openCV2.4.9,n安装过程以及相关配置都是按这个教程来的(没有说这个教程不好)nhttps://blog.csdn.net/bestgonghuibin/article/details/38409613n安装搭建环境都没有出现问题,但是最后在测试的时候,编译没有问题n显示生成文件,但是调试的时候就出现如下错误n![图片说明](https://img-ask.csdn.net/upload/201805/10/1525937295_679288.png)n![图片说明](https://img-ask.csdn.net/upload/201805/10/1525937317_724796.png)n有没有大神知道这个该怎么修改?已经查了很多资料问了一些人但是还没有解决,着急QAQ
基础环境搭建好后的测试
环境搭建好后的测试一、官方grep案例二、官方wordcount案例 一、官方grep案例 在hadoop-2.7.2文件下面创建一个input文件夹:mkdir input 将hadoop的xml配置文件复制到input:cp etc/hadoop/*.xml input 3.执行share目录下的mapreduce程序:bin/hadoop jar share/hadoop/mapreduc...
VS2010在连接数据库时出现的问题
明明已将数据库连接好了的啊,在server explorer中的DataConnections目录下有我设置的连接的数据库啊,而且数据库中也有table项,可是运行的时候仍然显示:未发现数据源名称且未指定默认驱动程序?rn请问默认驱动程序是如何指定啊?rn
测试环境搭建(测试环境搭建)
测试环境搭建(测试环境搭建)测试环境搭建(测试环境搭建)测试环境搭建(测试环境搭建)测试环境搭建(测试环境搭建)测试环境搭建(测试环境搭建)测试环境搭建(测试环境搭建)测试环境搭建(测试环境搭建)测试环境搭建(测试环境搭建)
OpenGL windows环境搭建和vs2010测试工程
OpenGL windows环境搭建和vs2010测试工程 详细过程可参见: http://blog.csdn.net/wangdingqiaoit/article/details/21104337
测试页面时出现的问题
调试页面时出现如下提示:rn“/news”应用程序中的服务器错误。rn--------------------------------------------------------------------------------rnrn用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。 rn说明: 执行当前 Web 请求期间,出现未处理的异常。请检查堆栈跟踪信息,以了解有关该错误以及代码中导致错误的出处的详细信息。 rnrn异常详细信息: System.Data.SqlClient.SqlException: 用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。rnrn源错误: rnrn执行当前 Web 请求期间生成了未处理的异常。可以使用下面的异常堆栈跟踪信息确定有关异常原因和发生位置的信息。 rnrn堆栈跟踪: rnrnrn[SqlException: 用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。]rn System.Data.SqlClient.SqlConnection.Open() +761rn NewsXP.NewsDB.GetNewsTotalRows(Int32 categoryID) in D:\News\Components\NewsDB.cs:63rn NewsXP.WebForm1.BindData() in D:\News\Default.aspx.cs:52rn NewsXP.WebForm1.Page_Load(Object sender, EventArgs e) in D:\News\Default.aspx.cs:34rn System.Web.UI.Control.OnLoad(EventArgs e) +67rn System.Web.UI.Control.LoadRecursive() +29rn System.Web.UI.Page.ProcessRequestMain() +724rnrn 请各位帮忙指点如何改rn
nginx配置好后,访问时出现crossdomain.xml
近期配置nginx做反向代理,访问某些页面出现会自动下载crossdomain.xml文件,且访问地址如下: http://backend/crossdomain.xml    查名原因为flexpaper在线预览功能会导致自动去查询此xml文件。    解决方法:    1、在项目根目录下创建crossdomain.xml内容如下:                  
vs2010中文版变成英文版后出现的问题
已安装sp1 mvc2 mv3 .net4.0,但打开以前正常的项目时提示rnthe preoject type are not supported by this installationrnrn英语可能拼错了哈,各位能看懂就行了rn该如何解决?rn已经百度谷歌 过了rn没法解决
VS2010项目升级到VS2015时出现的问题
1:“错误 D8016 “/ZI”和“/Gy-”命令行选项不兼容 ”问题 解决设置如下图: 图一: 图二: 2:微软让Socket新函数代替旧函数引起的编译错误,error C4996 error C4996: ‘inet_addr’: Use inet_pton() or InetPton() instead or define _WINSOCK_DEPRECATED_
VC6转vs2010 时出现
[code=text]1>c:\program files (x86)\microsoft visual studio 10.0\vc\atlmfc\include\atlsimpstr.h(415): error C2872: “UINT_PTR”: 不明确的符号rn1> 可能是“c:\program files (x86)\microsoft sdks\windows\v7.0a\include\basetsd.h(136) : __w64 unsigned int UINT_PTR”rn1> 或 “g:\工作文件日期\20180109企业版控件升级\ktsedocaxex\debug\mshtml.tlh(1322) : MSHTML::UINT_PTR”rn1> c:\program files (x86)\microsoft visual studio 10.0\vc\atlmfc\include\atlsimpstr.h(413): 编译类 模板 成员函数“void ATL::CSimpleStringT::Append(const char *,int)”时rn1> withrn1> [rn1> BaseType=char,rn1> t_bMFCDLL=truern1> ]rn1> c:\program files (x86)\microsoft visual studio 10.0\vc\atlmfc\include\afxstr.h(86): 参见对正在编译的类 模板 实例化“ATL::CSimpleStringT”的引用rn1> withrn1> [rn1> BaseType=char,rn1> t_bMFCDLL=truern1> ]rn1>[/code]rn “UINT_PTR”: 不明确的符号 ??? 这是为什么报出来 有人知道怎么解决吗。rn双击出错的位置跳转到rnc:\program files (x86)\microsoft visual studio 10.0\vc\atlmfc\include\atlsimpstr.h(415): error C2872: “UINT_PTR”:rn有大神解决这个问题吗?
测试环境搭建问题请教
关于测试环境搭建有问题想请教一下各位大神,功能测试及性能测试需要搭建不同的测试环境,考虑到搭建测试环境的投入较大,请问如何才能做到在合理的投入下完成测试环境的搭建,同时保证测试环境搭建的质量呢?rnrn谢谢呀~
测试环境搭建问题分享
测试环境搭建问题分享
JBOSS配置好后测试的问题
在LINUXAS5上装好JBOSS,在.bash_profile中也设置好了JAVA_HOME,JBOSS_HOME,CLASSPATH,PATHrn现在用IE打开,输入http://localhost:8080和http://127.0.0.1:8080显示正常,rn 输入http://192.168.1.4:8080(假设服务器的地址为192.168.1.4)就是报网页无法找到rn我是刚接触到JAVA,请各位帮忙解答一下,谢谢
关于tensorflow安装过程后启动测试时出现的问题
2018-04-26 11:38:12.800223: I tensorflow/core/platform/cpu_feature_guard.cc:140] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA 无解,目前
测试环境搭建
其实一般的测试环境搭建:就是开发写好了本次版本的代码,测试环境停止服务,上传,然后在重启服务,就是部署 比如开发改了之前的一个包,有时候是别的东西比如图片什么的,就需要去后台,把程序停掉,去系统固定目录将原来的文件重命名,替换成最新的包,然后在重启服务进程,就可以去测试了;一般jar包放在lib目录下,war包放在webapps目录下 以前在Linux上搭建环境,安装jdk,tomacat,My...
VS2010出现的问题
使用VS2010进行C++编程练习时候,碰到了两个问题:rn1 程序安装好了以后,安装帮助文档(msdn),通过help——》管理帮助文档,发现不能出现对话框,进行选择本地安装,甚至出现“管理帮助文档”点击后,没有任何反应,从百度里面搜了各种应对策略,基本上没有可用的解决方法,特向高手请教?rnrn2 打开VS2010主界面,建立工程后,新建一个CPP文档,发现出现如下错误提示:rn [i]VisualStudio遇到了异常,这可能是由某个扩展导致的。rn 您可以在命令行上使用/log参数运行程序,然后检查文件“C:\User\rn Administrator\AppData\Roaming\Microsoft\VisualStudio\10.0\rn ActivityLog.xml”以获取详细信息[/i]
vs2010出现的问题
vs2010出现的问题,怎么解决?rnrn未能加载文件或程序集“CrystalDecisions.Web, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304”或它的某一个依赖项。系统找不到指定的文件。
VS2010程序出现了问题
我用VS2010写的程序在自己电脑上运行正确,在其他电脑上就死掉,不只是什么原因造成的。rn[img=https://img-bbs.csdn.net/upload/201409/13/1410618038_804692.jpg][/img]rn问题签名:rn 问题事件名称: APPCRASHrn 应用程序名: dream梦凡.exern 应用程序版本: 0.0.0.0rn 应用程序时间戳: 54142363rn 故障模块名称: dream梦凡.exern 故障模块版本: 0.0.0.0rn 故障模块时间戳: 54142363rn 异常代码: c0000005rn 异常偏移: 0000a3dern OS 版本: 6.1.7601.2.1.0.256.1rn 区域设置 ID: 2052rn 其他信息 1: 0a9ern 其他信息 2: 0a9e372d3b4ad19135b953a78882e789rn 其他信息 3: 0a9ern 其他信息 4: 0a9e372d3b4ad19135b953a78882e789
装完VS2010出现了问题
曾经装了vs2012,后来删除掉,又装20010,有问题,现在重新装2012的时候不知什么原因打不开.exe文件了,最后还是选择装2010,装好后出现1>------ 已启动生成: 项目: 123, 配置: Debug Win32 ------n1>生成启动时间为 2015/10/5 11:38:11。n1>InitializeBuildStatus:n1> 正在对“Debug\123.unsuccessfulbuild”执行 Touch 任务。n1>ClCompile:n1> 所有输出均为最新。n1> 所有输出均为最新。n1>ResourceCompile:n1> 所有输出均为最新。n1>LINK : fatal error LNK1123: 转换到 COFF 期间失败: 文件无效或损坏n1>n1>生成失败。n1>n1>已用时间 00:00:00.38n========== 生成: 成功 0 个,失败 1 个,最新 0 个,跳过 0 个 ==========nn根据网友的解答方案,把网上有的什么VS2010在经历一些更新后,建立Win32 Console Project时会出“error LNK1123” 错误,解决方案为:nn将 项目|项目属性|配置属性|清单工具|输入和输出|嵌入清单 “是”改为“否”即可,但是每新建一个项目都要这样设置一次。nn nn 若按照上面解决方案依然发生“error LNK1123”错误,解决方案如下:nn 在电脑中搜索查看是否有多个cvtres.exe。nn 比如其中:nn 一个是C:\Program Files(x86)\Microsoft Visual Studio 10.0\vc\bin\cvtres.exe nn 一个是C:\Windows\Microsoft.NET\Framework\v4.0.30319\cvtres.exe。nn 右键属性|详细信息 查看两者版本号,删除/重命名较旧的版本,或者重新设置Path变量。nnn注意:此方法为治本的办法,删除旧版本的cvtres.exe后,就不需要每次都设置配置了。nn 这些都用了,都不行,现在想问是不是当初删2012的时候把C盘的本来重要的东西删了,还有什么可能
qt和vs2010的环境搭建
问题1:如何将qt的工程指定转换成vs2010版本的。rn转换qt5.2安装后就有的官方例子,系统装了vs2010和vs2008.在vs2010的菜单中选择,用qt的插件,打开qt工程的pro文件,转换后是2008版本的工程。问如何直接转换成2010工程的项目。rnrn问题2:Qt 工程转换为vs2010的工程后Release版本编译通不过。rn1个警告1个错误。rnMicrosoft.CppBuild.Targets(298,5):warning MSB8004:Intermediate 目录未以斜杠结尾。rnMicrosoft.Win32.Targets(153,5):元素具有无效的“None”。rnrn问题3:在vs2010上选择新建qt工程后,如何转换为qt工程。rnvs2010新建的QT工程可以编译Release版本,但是不知道如何转换为Qt工程。使用qmake自动生成工程后,在linux下是编译通不过的。rn
QT4.8.6和VS2010环境搭建
首先下载QT4.8.6的安装包、QT Addin 1.11插件和VS2010安装包。 第一步:安装好VS2010 第二步:安装QT4.8.6                刚刚安装了一下,所有的配置都不用改,按照步骤来就行。默认安装在C:\\QT4.8.6 第三步:安装QT Addin 1.11插件               插件也是什么都不用改,按照默
nasm vs2010 汇编环境搭建
压缩包内有必要文件和说明文档.有汇编高亮插件
Solidworks2015和vs2010二次开发的环境搭建
Solidworks2015和vs2010二次开发的环境搭建,经过本人的亲自试用。
QT + VS2010 环境搭建
1、安装qt-vs-addin-1.1.11-opensource.exe 2、安装qt-win-opensource-4.7.1-vs2008.exe 3、把Qt4.7.1(VS10).zip解压到自己指定的目录,最好与qt-win-opensource-4.7.1-vs2008.exe安装目录同级,假如为C:\Qt\4.7.1_VS10 4、配置环境变量
Windows编译环境搭建(VS2010)
引言: 本篇文章基于教程目的(由于windows和linux相关环境搭建篇幅过大,在博客中做这些讲解),主要描述Windows的发展历程和编译环境搭建(基于 Visual Studio 2010版本)。 正文: 日常生活中,Windows是我们最常见到的操作系统之一,在编程领域也占据着主要地位。也许你有一些疑问,比如“Windows在编程界为什么有如此巨大的魅力?”,在本篇文章中对答案进行揭晓。 ...
Maven环境搭建,出现的问题
给大家分享下在搭建maven遇到的一个问题: 在执行cmd命令时,出现的错误,解决方法如下: 1.在电脑中找到环境变量,然后如下找到JAVA_HOME,点编辑: 2.在jdk.1.8.0后面加上_144即可 3.在重新打开cmd命令执行,这样既成功了: ...
RN 环境搭建出现的问题
在RN 的环境中配置出现问题,crn 封装的rn 的信息,出现问题,通常会执行crn-cli run patch 去解决,但是发现实际使用过程中crn-cli 的命令找不到, 是node 的版本 不一致导致的, 解决方案!1、 删除原有nodebrew remove –force node sudo rm -r /usr/local/lib/node_modulessudo rm -rf /us
SSH整合之Spring环境搭建测试出现的小问题
创建一个User Library 里面存放的是项目所需jar 在把本地jar文件导入到相应的library时,创建Spring3-Core时 ,我选择了System library (added to the boot class path) 然后把 中文命名 文件中的所需jar导入了。 没错,问题就出现在了“中文命名”的文件夹上了。 【applicationContex...
安装vs2010后vs2008打开数据库时出现错误
Failed to generate a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed.rnrnrn请问怎么解决这个问题呢
添加GPSR模块后测试出现的问题
添加GPSR协议后,首先得验证一下ns-3.26是不是还好使。结果这一测试,真的出了问题。好烦啊......问题一(已经解决):从以前的最简单的测试开始,把first.cc复制到scratch目录下:mayunteng@machine:~/tarballs/ns-allinone-3.26/ns-3.26$ cp examples/tutorial/first.cc scratch/ 然后在ns-...
手动测试fabric网络时出现的问题
1:  创建channel时出现Error: Got unexpected status: BAD_REQUEST      可能是该名称的channel已经存在了,执行:peer channel list            发现mychannel渠道已经建立了,所以不用再重复的创建了!     2: 将渠道加入这个创世区块上时:peer channel join -b mychann
一些UiAutomator测试时出现的问题
1、UiDevice not initialized 2、Injecting to another application requires INJECT_EVENTS permission 3、Unable to connect to adb. Check if adb is installed correctly
安装scipy,测试时出现的问题
在安装scipy后,进行“import scipy;scipy.testa()"测试时,出现问题:Traceback (most recent call last):  File "<stdin>", line 1, in <module>  File "/usr/local/lib/python2.7/dist-packages/scipy/_lib/_testutils...
测试Gadget时,IE7下出现的问题
一个比较弱智的错误:   function initSPI(){       xxx.Request.setService("community", { getMostFollowedContent: { service: "community.getMostFollowedContent", ...
在NetBeans5.5进行测试时出现的问题?
在NetBeans5.5种进行Junit测试时,总是提示找不到junit.framework软件包,可在测试库中明明存在?
测试string.Replace及string.Remove时出现的问题
public string love(string str1,string str2,char bs)rn rn str2=str1.Replace(str2,bs.ToString());rn return str2;rn rnrnrnrnprivate void Button3_Click(object sender, System.EventArgs e)rn rn string love=this.love("aa,bb,cc,dd,","aa",'n');rn Response.Write (love.Remove(love.Length-1,1));rn//打印出来为n,bb,cc,ddrn Response.Write(" ");rn rn string str1="aa,bb,cc,dd,";rn string str2="aa";rn char bs='n';rn str2=str1.Replace(str2,bs.ToString());rn str2=str2.ToString();rn str2.Remove(str2.Length-1,1);rn Response.Write (str2);rn//打印出来为:n,bb,cc,dd, rn rn为什么会出现这种情况啊,我想不明白,我认为道理都是一样的啊,只是处理的地方不同而已rn
连接池测试时出现的变态问题
环境:JDK4 TOMCAT-4.1.28 MySQL 4.0.18-nt(mysql-connector-java-3.1.0-alpha-bin.jar)rnrn数据库TestDB里表user:rn Id bigint(20) NOT NULL auto_incrementrn UserName varchar(20) NOT NULLrn有两条记录,不涉及中文。rnrnrn测试代码:rn<%@ page contentType="text/html;charset=gb2312" %> rn<%@ page language="java" import="java.sql.*,javax.naming.*,javax.sql.*" %>rn<%rnrnrn tryrn rn Context ctx = new InitialContext(); rn DataSource ds = (DataSource)ctx.lookup("java:comp/env/jdbc/TestDB");rnrnrn if (ds != null) rn Connection conn = ds.getConnection(); rn rn if(conn != null) rn Statement stmt = conn.createStatement();rn ResultSet rst = stmt.executeQuery("select * from user");rn while(rst.next()) rn //out.println("id:" + rst.getInt(1));rn out.println("username:" + rst.getString(2)); rn out.println(" ");rn rn out.println("ok");rn if(rst!=null) rst.close();rn if(stmt!=null) stmt.close();rn if(conn!=null) conn.close();rn rn rn rn rn rn rn catch(Exception e) rn e.printStackTrace();rn rnrnrn%>rnrn每一步都测试成功,但在显示select结果的时候有问题。rn1)//out.println("id:" + rst.getInt(1));rn out.println("username:" + rst.getString(2)); rn 没有报错,但显示不出表记录。rn2)out.println("id:" + rst.getInt(1));rn out.println("username:" + rst.getString(2)); rn 报错 Invalid value for getInt() - 'p' rn3)out.println("id:" + rst.getInt("Id"));rn out.println("username:" + rst.getString("UserName")); rn 报错 找不到字段rnrn这个问题折腾我好久了,请教大家,多谢!
测试声明异常处理时出现的问题
使用一个servlet来处理HTTP错误rn其代码中有rnInteger status_code = (Integer)request.getAttribute("javax.servlet.error.status_code");rnif(status_code.intValue() == 401)……处理401过程……rnif(status_code.intValue() == 404)……处理404过程……rnrnrn并且在web.xml中设置rnrn 401rn /EHSrnrn rnrn 404rn /EHSrnrnrn当产生401错误时,该异常处理程序可以处理401错误,显示相关的错误页面rn但是当产生404错误时,该异常处理程序则没有任何反映,IE显示的是默认的找不到网页的页面rnrn请问这个是怎么回事?
用vs2010测试遇到的问题
在执行测试方法的时候,报错:rnMySql.Data.MySqlClient.MySqlException: Access denied for user ''@'localhost' (using password: NO)。rn求解决方案
交叉编译环境搭建时的问题
配置完环境之后运行: arm-linux-gnueabihf-gcc -v 提示: arm-linux-gnueabihf-gcc: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory 解决办法:因为我的系统是u
相关热词 c# xml的遍历循环 c# 取 查看源码没有的 c#解决高并发 委托 c#日期转化为字符串 c# 显示问号 c# 字典对象池 c#5.0 安装程序 c# 分页算法 c# gmail 发邮件 c# 多层文件