springmvc+jfreechart导入包出错

spring3.0+ibatis2.3.4
tomcate7+jdk1.6
eclipse3.2
导入jfreechart三个相关包gnujaxp.jar、jcommon-1.0.17.jar、jfreechart-1.0.14.jar之前能正常运行。
导入之后,启动tomcat就报错:
nested exception is javax.xml.parsers.ParserConfigurationException: Unable to validate using XSD: Your JAXP provider [[color=#FF0000]gnu.xml.dom.JAXPFactory@1381960[/color]] does not support XML Schema. Are you running on Java 1.4 with Apache Crimson? Upgrade to Apache Xerces (or Java 1.5) for full XSD support.

网上查了相关的问题,说什么jar冲突之类的,我没发现。没有找到一个具体的解决方法。
谢谢各位大神啦!

1个回答

把 gnujaxp.jar 删了。。。

iteye_5246
iteye_5246 哥们,提示 Are you running on Java 1.4 with Apache Crimson? Upgrade to Apache Xerces (or Java 1.5) for full XSD support 其中[Upgrade to Apache Xerces (or Java 1.5) for full XSD support. ] 说java 1.5的完全支持。所以推断出。这个包在java1.5 没用。
大约 7 年之前 回复
zhourenming
zhourenming 成功了! 话说:gnujaxp.jar不是Jfreechart的必须包吗?怎可不要呢???
大约 7 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问