webpack 引入vue,在vue中使用 mint-ui

在引入mint-ui 的文件和style.css 的时候,总是报下面的错误,不知道大神们怎么解决

ERROR in ./node_modules/_mint-ui@1.0.2@mint-ui/lib/popup/style.css
Module build failed: CssSyntaxError

(2:1) Unknown word

  1 | 
> 2 | var content = require("!!./style.css");
    | ^
  3 | 
  4 | if(typeof content === 'string') content = [[module.id, content, '']];

 @ ./node_modules/_mint-ui@1.0.2@mint-ui/lib/mint-ui.common.js 5052:18-56
 @ ./src/main.js
 @ multi ./node_modules/_webpack-dev-server@2.11.3@webpack-dev-server/client?http://localhost:3000 webpack/hot/dev-server ./src/main.js

2个回答

网上找的:在百度上搜索了很多文章,都说将webpack.config.js里面的{test: /.css$/, loader: 'css-loader!style-loader'}修改为{test: /.css$/, loader: 'style-loader!css-loader'},但是修改后还是报错,后来在一篇文章中看到说是在git上看到的,将这个配置直接删除掉,就可以了,试过了,确实没报错了。有些是这种的{test: /.css$/,use: ['style-loader', 'css-loader', 'postcss-loader'] },我的也是这种的,删除掉,就不报错了!

weixin_38297879
Aondoe 我没有这样,将mint-ui卸载掉,重新安装就好了。
一年多之前 回复

看官方文档引入,我每次引入没有一点错

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐