Ubuntu系统Pycharm安装Scrapy相关的包libxml2dom时报了个错SyntaxError: invalid syntax

图片说明
就是这个

Collecting libxml2dom
  Using cached https://files.pythonhosted.org/packages/03/13/835078254cffd5cf19cae3ca5782aae4120c86c888a0beb1c26390a5d6d6/libxml2dom-0.4.7.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pycharm-packaging/libxml2dom/setup.py", line 5, in <module>
        import libxml2dom
      File "/tmp/pycharm-packaging/libxml2dom/libxml2dom/__init__.py", line 151
        raise KeyError, name
                      ^
    SyntaxError: invalid syntax

    ----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in /tmp/pycharm-packaging/libxml2dom/

最好是能帮我分析一下为什么会这样?谢谢大神们了
图片说明
其他的包都正常安装,就这个包没看懂怎么回事求大神解答!!
图片说明

1个回答

把libxml2dom卸载再装?
如果不行的话换成python3.5再试一下

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问