skye丶 2022-01-05 12:55 采纳率: 50%
浏览 115
已结题

webstorm总是自动下载旧版本的react-router-dom

最近想试一下v6的react-router-dom,然后就安装了^6.2.1的包

img

然后就发现我这2020.3的webstorm一直会自动下载5.3.0的react-router-dom,然后默认使用这个包

img

删掉后只要连上网就会换成5.3.0的版本

另外react-dom也是用的webstorm自己下载的,虽然版本一样

img

项目是用create-react-app 5.0新建的,packagejson-lock里面也没有相关内容,实在找不到哪里设置的了

就想用个新版本怎么那么难

  • 写回答

1条回答 默认 最新

报告相同问题?

问题事件

  • 系统已结题 1月13日
  • 已采纳回答 1月5日
  • 修改了问题 1月5日
  • 创建了问题 1月5日

悬赏问题

  • ¥15 GENESYS无法找到EESoft Flexnet Licence Serve
  • ¥15 流式socket文件传输答疑
  • ¥20 keepalive配置业务服务双机单活的方法。业务服务一定是要双机单活的方式
  • ¥50 关于多次提交POST数据后,无法获取到POST数据参数的问题
  • ¥15 win10,这种情况怎么办
  • ¥15 如何在配置使用Prettier的VSCode中通过Better Align插件来对齐等式?(相关搜索:格式化)
  • ¥100 在连接内网VPN时,如何同时保持互联网连接
  • ¥15 MATLAB中使用parfor,矩阵Removal的有效索引在parfor循环中受限制
  • ¥20 Win 10 LTSC 1809版本如何无损提升到20H1版本
  • ¥50 win10 LTSC 虚拟键盘不弹出