编程介的小学生 2019-05-30 11:13 采纳率: 20.5%
浏览 722

判断第二个矩阵是不是第一个矩阵的子矩阵,怎么用C语言的程序的代码的编写的思想的方式去实现的程序

Problem Description
There is a matrix of size n*n whose elements are either 0 or 1. Now your task is to find out that given a matrix of size m*m whose elements are also 0 or 1 whether it is a sub-matrix of the previous matrix.

Input
There is a matrix of size n*n whose elements are either 0 or 1. Now your task is to find out that given a matrix of size m*m whose elements are also 0 or 1 whether it is a sub-matrix of the previous matrix.

Output
If the second matrix is a sub-matrix of the first one, print “Yes” on a single line. Otherwise print “No”.

Sample Input
4 2
0 0 0 1
0 1 0 1
1 0 1 0
0 0 0 0
1 0
0 0
3 2
0 0 1
0 1 0
1 0 0
0 0
1 1

Sample Output
Yes
No

  • 写回答

1条回答 默认 最新

  • I__like__c 2021-12-05 20:12
    关注

    #include<stdio.h>
    int main()
    {
    int a[10][10],b[10][10],N,M,x=-1,y,flag,i,j;
    scanf("%d",&N);
    for(int i=0; i<N; i++)
    {
    for(int j=0; j<N; j++)
    {
    scanf("%d",&a[i][j]);
    }
    }
    scanf("%d",&M);
    for(int i=0; i<M; i++)
    {
    for(int j=0; j<M; j++)
    {
    scanf("%d",&b[i][j]);
    }
    }
    for(i=0; i<=N-M; i++)
    {
    for(j=0; j<=N-M; j++)
    {
    if(a[i][j]==b[0][0])
    {
    flag=1;
    for(int k=0; k<M; k++)
    {
    for(int u=0; u<M; u++)
    {
    if(a[i+k][j+u]!=b[k][u])
    flag=-1;
    }
    }
    if(flag==1)
    {
    y=i;
    x=j;
    }
    break;
    }
    }
    }
    if(x!=-1) printf("%d,%d",y+1,x+1);

    else printf("-1");
    return 0;
    

    }

    评论

报告相同问题?

悬赏问题

  • ¥15 R语言Rstudio突然无法启动
  • ¥15 关于#matlab#的问题:提取2个图像的变量作为另外一个图像像元的移动量,计算新的位置创建新的图像并提取第二个图像的变量到新的图像
  • ¥15 改算法,照着压缩包里边,参考其他代码封装的格式 写到main函数里
  • ¥15 用windows做服务的同志有吗
  • ¥60 求一个简单的网页(标签-安全|关键词-上传)
  • ¥35 lstm时间序列共享单车预测,loss值优化,参数优化算法
  • ¥15 Python中的request,如何使用ssr节点,通过代理requests网页。本人在泰国,需要用大陆ip才能玩网页游戏,合法合规。
  • ¥100 为什么这个恒流源电路不能恒流?
  • ¥15 有偿求跨组件数据流路径图
  • ¥15 写一个方法checkPerson,入参实体类Person,出参布尔值