2015-05-07 06:25
浏览 96

错误400:阻止将PHP 5.4应用程序部署到Google App Engine

This is my app.yaml file:

application: xxxxxxxxxxxxx
version: 1
runtime: php55
api_version: 1
threadsafe: true


- url: /images
  static_dir: images

- url: /css
  static_dir: css

- url: /js
  static_dir: js

- url: /libraries
  static_dir: libraries

- url: /
  script: main.php

# Serve php scripts.
- url: /(.+\.php)$
  script: \1

This is the error I get:

Error 400: --- begin server output ---

PHP 5.4 applications are prevented from being deployed to Google App Engine from any version of the SDK, including older ones. If you need to continue to deploy PHP 5.4 applications for compatibility reasons, you can request that your application be whitelisted for PHP 5.4 deployment by visiting http://goo.gl/qjKEuk.

--- end server output ---

Can somebody please tell me why I still get this error after changing runtime from php to php55 in app.yaml?

图片转代码服务由CSDN问答提供 功能建议

这是我的 app.yaml 文件: < pre> application:xxxxxxxxxxxxx version:1 runtime:php55 api_version:1 threadsafe:true handlers: - url:/ images static_dir:images - url: / css static_dir:css - url:/ js static_dir:js - url:/ libraries static_dir:libraries - url:/ script:main.php #提供php脚本。 - url:/(.+\.php)$ 脚本:\ 1

这是错误 我得到:


PHP 5.4应用程序无法部署 从任何版本的SDK到Google App Engine,包括旧版本。 如果出于兼容性原因需要继续部署PHP 5.4应用程序,可以访问 http,请求将您的应用程序列入白名单以进行PHP 5.4部署。 ://goo.gl/qjKEuk


有人可以告诉我为什么在 app 中将 runtime php 更改为 php55 后仍然会出现此错误 ?

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • dongza1708 2015-05-12 10:45

    PhpStorm plugin is still not compatible with deploying php55 apps. Deploying through Google App Engine Launcher works fine.

    打赏 评论
  • drzdu44226 2015-05-08 21:11

    You need to update your Google App Engine Launcher to 1.9.18 or higher. You can't use php55 with 1.9.17 (and I just updated to 1.9.20 and it is a bit different, uses your browser to log in).

    打赏 评论