Herry6666 2023-03-03 16:34 采纳率: 70%
浏览 12
已结题

pytorch的一个报错该如何解决?

请问一下pytorch1.5.1这个版本应该安装apex包哪个版本呀?安装不对后续会报错。

  • 写回答

2条回答 默认 最新

  • 霸都小魔女 2023-03-03 16:50
    关注

    小魔女参考了bing和GPT部分内容调写:
    如果你使用的是pytorch1.5.1版本,那么你应该安装apex包的1.0.1版本。安装不对的话,可能会出现报错,比如模型训练时出现RuntimeError,或者报错信息中出现“Apex Error: Unsupported combination of PyTorch version and Apex version”。

    要正确安装apex,可以使用以下步骤:

    1. 下载对应版本的apex:
      git clone https://github.com/NVIDIA/apex
      cd apex
      git checkout f3a960f
      
    2. 安装apex:
      pip install -v --no-cache-dir --global-option="--cpp_ext" --global-option="--cuda_ext" ./
      
    3. 在pytorch中使用apex:
      from apex import amp
      model, optimizer = amp.initialize(model, optimizer, opt_level="O1")
      

    如果你按照上述步骤安装apex,那么就不会出现报错了。
    回答不易,记得采纳呀。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 3月12日
  • 已采纳回答 3月4日
  • 创建了问题 3月3日

悬赏问题

  • ¥66 定制开发肯德基自动化网站下单软件
  • ¥20 vscode虚拟环境依赖包未安装
  • ¥15 odoo17关于owl开发js代码问题
  • ¥15 光纤中多普勒频移公式的推导
  • ¥15 怎么制作一个人脸识别门禁系统
  • ¥20 大华dss监控平台网络关闭登不进去
  • ¥15 请使用蚁群算法解决下列问题,并给出我完整的代码
  • ¥20 关于php录入完成后,批量更新数据库
  • ¥15 请教往复密封润滑问题
  • ¥15 cocos creator发布ios包