dtt5830659 2016-01-11 05:36
浏览 144
已采纳

通过Composer解决项目中的Git repo问题?

I'm working with Composer to pull in libraries, and I'm struggling with something. Here is the composer.json that I'm working with:

{
  "require": {
    "mike182uk/paypal-ipn-listener": "~4.0"
  },
  "repositories": [
    {
      "type": "git",
      "url": "https://github.com/angelleye/filemakerapi.git"
    }
  ]
}

When I run composer update it's pulling in the paypal-ipn-listener stuff, but it's not pulling in the filemakerapi stuff.

What's strange is the first time I ran it I did see that it went through all the different tags in the repo, and showed the versions (9.0, 10.0, 11.0, etc.) but then it ended up telling me "nothing to install or update."

Now when I run it I just get that same message that there is simply nothing to install or update.

I also tried this for the repositories part instead...

  "repositories": [
    {
      "type": "vcs",
      "url": "https://github.com/angelleye/filemakerapi"
    }
  ]

I get the same result with both of those methods, though. I can't figure out why it won't actually pull in the master branch or a tagged version of that repo.

Any information on what I'm doing wrong here would be greatly appreciated. Thanks!

  • 写回答

1条回答 默认 最新

  • donglian4770 2016-01-11 05:40
    关注

    Adding a repository doesn't automatically pull in the code. It just tells composer where it should look to meet dependencies.

    You will need to add a require entry for matatirosoln/filemaker-api (the package name in that repo's composer.json) in order for it to pull in that dependency.

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥20 ML307A在使用AT命令连接EMQX平台的MQTT时被拒绝
  • ¥20 腾讯企业邮箱邮件可以恢复么
  • ¥15 有人知道怎么将自己的迁移策略布到edgecloudsim上使用吗?
  • ¥15 错误 LNK2001 无法解析的外部符号
  • ¥50 安装pyaudiokits失败
  • ¥15 计组这些题应该咋做呀
  • ¥60 更换迈创SOL6M4AE卡的时候,驱动要重新装才能使用,怎么解决?
  • ¥15 让node服务器有自动加载文件的功能
  • ¥15 jmeter脚本回放有的是对的有的是错的
  • ¥15 r语言蛋白组学相关问题