将Laravel从5.3升级到5.4

My project is working on 5.3 laravel version and trying to upgrade it.

I have updated composer.json as guided into the documentation of laravel guide. And run command composer update on command line.

I am getting following error.

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don't install laravel/framework v5.4.36
- Conclusion: don't install laravel/framework v5.4.35
- Conclusion: don't install laravel/framework v5.4.34
- Conclusion: don't install laravel/framework v5.4.33
- Conclusion: don't install laravel/framework v5.4.32
- Conclusion: don't install laravel/framework v5.4.31
- Conclusion: don't install laravel/framework v5.4.30
- Conclusion: don't install laravel/framework v5.4.29
- Conclusion: don't install laravel/framework v5.4.28
- Conclusion: don't install laravel/framework v5.4.27
- Conclusion: don't install laravel/framework v5.4.26
- Conclusion: don't install laravel/framework v5.4.25
- Conclusion: don't install laravel/framework v5.4.24
- Conclusion: don't install laravel/framework v5.4.23
- Conclusion: don't install laravel/framework v5.4.22
- Conclusion: don't install laravel/framework v5.4.21
- Conclusion: don't install laravel/framework v5.4.20
- Conclusion: don't install laravel/framework v5.4.19
- Conclusion: don't install laravel/framework v5.4.18
- Conclusion: don't install laravel/framework v5.4.17
- Conclusion: don't install laravel/framework v5.4.16
- Conclusion: don't install laravel/framework v5.4.15
- Conclusion: don't install laravel/framework v5.4.14
- Conclusion: don't install laravel/framework v5.4.13
- Conclusion: don't install laravel/framework v5.4.12
- Conclusion: don't install laravel/framework v5.4.11
- Conclusion: don't install laravel/framework v5.4.10
- Conclusion: don't install laravel/framework v5.4.9
- Conclusion: don't install laravel/framework v5.4.8
- Conclusion: don't install laravel/framework v5.4.7
- Conclusion: don't install laravel/framework v5.4.6
- Conclusion: don't install laravel/framework v5.4.5
- Conclusion: don't install laravel/framework v5.4.4
- Conclusion: don't install laravel/framework v5.4.3
- Conclusion: don't install laravel/framework v5.4.2
- Conclusion: don't install laravel/framework v5.4.1
- cartalyst/stripe-laravel v5.0.1 requires illuminate/support 5.3.* -> satisfiable by laravel/framework[v5.3.31], illuminate/support[v5.3.0, v5.3.16, v5.3.23, v5.3.4].
- cartalyst/stripe-laravel v5.0.0 requires illuminate/support 5.3.* -> satisfiable by laravel/framework[v5.3.31], illuminate/support[v5.3.0, v5.3.16, v5.3.23, v5.3.4].
- cartalyst/stripe-laravel v5.0.1 requires illuminate/support 5.3.* -> satisfiable by laravel/framework[v5.3.31], illuminate/support[v5.3.0, v5.3.16, v5.3.23, v5.3.4].
- Can only install one of: laravel/framework[v5.4.0, v5.3.31].
- don't install illuminate/support v5.3.0|don't install laravel/framework v5.4.0
- don't install illuminate/support v5.3.16|don't install laravel/framework v5.4.0
- don't install illuminate/support v5.3.23|don't install laravel/framework v5.4.0
- don't install illuminate/support v5.3.4|don't install laravel/framework v5.4.0
- Installation request for laravel/framework 5.4.* -> satisfiable by laravel/framework[v5.4.0, v5.4.1, v5.4.10, v5.4.11, v5.4.12, v5.4.13, v5.4.14, v5.4.15, v5.4.16, v5.4.17, v5.4.18, v5.4.19, v5.4.2, v5.4.20, v5.4.21, v5.4.22, v5.4.23, v5.4.24, v5.4.25, v5.4.26, v5.4.27, v5.4.28, v5.4.29, v5.4.3, v5.4.30, v5.4.31, v5.4.32, v5.4.33, v5.4.34, v5.4.35, v5.4.36, v5.4.4, v5.4.5, v5.4.6, v5.4.7, v5.4.8, v5.4.9].
- Installation request for cartalyst/stripe-laravel 5.0.* -> satisfiable by cartalyst/stripe-laravel[v5.0.0, v5.0.1].

This is composer.json

{
"name": "laravel/laravel",
"description": "The Laravel Framework.",
"keywords": ["framework", "laravel"],
"license": "MIT",
"type": "project",
"require": {
    "php": ">=5.5.9",
    "laravel/framework": "5.4.*",
    "intervention/image": "^2.3",
    "sly/notification-pusher": "^2.2",
    "baum/baum": "^1.1",

    "rtconner/laravel-tagging": "^2.0",
    "michele-angioni/laravel-js-lang-converter": "^2.1",
    "laravelcollective/html": "^5.2",
    "doctrine/dbal": "^2.5",
    "eluceo/ical": "^0.9.0",
    "twilio/sdk": "^4.10",
    "barryvdh/laravel-cors": "^0.8.1",
    "guzzlehttp/guzzle": "~6.0",
    "php-ffmpeg/php-ffmpeg": "^0.9.3",
    "cartalyst/stripe-laravel": "5.0.*"
},
"require-dev": {
    "fzaninotto/faker": "~1.4",
    "mockery/mockery": "0.9.*",
    "phpunit/phpunit": "~5.7",
    "symfony/css-selector": "3.1.*",
    "symfony/dom-crawler": "3.1.*"
},
"autoload": {
    "classmap": [
        "database",
        "app/Models",
      "app/Console/Commands"

    ],
    "files": [
      "app/helpers.php"
    ],
    "psr-4": {
        "App\\": "app/"
    }
},
"autoload-dev": {
    "classmap": [
        "tests/TestCase.php"
    ]
},
"scripts": {
    "post-install-cmd": [
        "php artisan clear-compiled",
        "php artisan optimize"
    ],
    "post-update-cmd": [
        "php artisan clear-compiled",
        "php artisan optimize"
    ],
    "post-create-project-cmd": [
        "php -r \"copy('.env.example', '.env');\"",
        "php artisan key:generate"
    ]
},
"config": {
    "preferred-install": "dist"
}
}

Any help will be appreciated!

Thanks.

查看全部
douhuo0884
douhuo0884
2017/11/10 06:45
  • laravel
  • php
  • 点赞
  • 收藏
  • 回答
    私信
满意答案
查看全部

1个回复