dongqiao0953
2017-09-18 14:32
浏览 169
已采纳

为PHP 5.5.9安装旧版本的Yaml(1.3.1)

I tried to install yaml by using this commands

 sudo apt-get install php-pear libyaml-dev
 sudo pecl install yaml

But this YAML requires php7.0 and newer version. I use PHP 5.5.9 How can install older version of YAML.

图片转代码服务由CSDN问答提供 功能建议

我尝试使用此命令安装yaml

  sudo  apt-get install php-pear libyaml-dev 
 sudo pecl install yaml 
   
 
 

但是这个YAML需要php7.0和更新版本。 我使用PHP 5.5.9 如何安装旧版本的YAML。

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

2条回答 默认 最新

  • doulou1970 2017-09-18 14:37
    最佳回答

    You should change your package repository (For example in Debian/Ubuntu Aptitude repositories), for PHP5 versions and then install that version or YAML.

    You can use also Composer for the dependencies management, or the "hardest" way, download the source code and implement by yourself.

    echo "deb http://packages.dotdeb.org wheezy-php56 all" >> /etc/apt/sources.list.d/dotdeb.list
    echo "deb-src http://packages.dotdeb.org wheezy-php56 all" >> /etc/apt/sources.list.d/dotdeb.list
    
    
    wget http://www.dotdeb.org/dotdeb.gpg -O- |apt-key add -
    
    apt-get update
    apt-get install php-pearl ....
    
    评论
    解决 无用
    打赏 举报
查看更多回答(1条)

相关推荐 更多相似问题