doufu6423
2016-12-12 10:30 阅读 40
已采纳

使用php 5.5.9的作曲家无法安装Laravel 5.2

I'm trying to set up a Laravel project on the server with php 5.5.9.

I've specially remembered to use Laravel 5.2 and only packages that support php 5.5, but I'm still getting errors, although Laravel itself says everything should be fine:

enter image description here

Any idea why is this doctrine/annotations suddenly asking for php 5.6?

Edit: This is my current composer.json file:

"require": {
    "php": ">=5.5.9",
    "laravel/framework": "5.2.*",
    "guzzlehttp/guzzle": "^6.2"
},
"require-dev": {
    "fzaninotto/faker": "~1.4",
    "mockery/mockery": "0.9.*",
    "phpunit/phpunit": "~4.0",
    "symfony/css-selector": "2.8.*|3.0.*",
    "symfony/dom-crawler": "2.8.*|3.0.*"
},
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

3条回答 默认 最新

  • 已采纳
    dongtiao2976 dongtiao2976 2016-12-12 10:39

    Run composer update first and then install laravel. I think this guy explains it very well copmposer update vs composer install

    点赞 评论 复制链接分享
  • dqqxkq4047 dqqxkq4047 2016-12-12 10:42

    Create Your laravel project using

    composer create-project --prefer-dist laravel/laravel Project_name "5.2.*"
    
    点赞 评论 复制链接分享
  • douzhang5295 douzhang5295 2016-12-12 10:47

    I also found that for some versions of Laravel, the doctrine and guzzlehttp dependencies are messed up. You need to install PHP 5.6 for this version of doctrine or test if 6.2 would work, for example

    "guzzlehttp/guzzle": ">=6.2"
    

    instead of

    "guzzlehttp/guzzle": "^6.2"
    

    (I got it working with PHP7, if you have no specific needs regarding the version, you could try that, too.)

    点赞 评论 复制链接分享

相关推荐