doujia8801
doujia8801
2016-12-14 21:20

vagrant + phansible - 无法获取PPA信息

已采纳

After setting up my configuration with phansible, and executing vagrant up

the provisioning process finishes with:

--
==> default: TASK [php : Add ppa Repository] ************************************************
==> default: fatal: [192.168.33.99]: FAILED! => {"changed": false, "failed": true, "msg": "failed to fetch PPA information, error was: HTTP Error 404: Not Found"}
--

Any suggestions on how I could get this working?

Thanks in advance!

--

provisioning script:

server:
    install: '1'
    packages: [git, imagemagick]
    timezone: Europe/Madrid
    locale: de_DE.UTF-8
vagrant_local:
    install: '1'
    vm: { base_box: trusty64, hostname: default, ip: 192.168.56.101, memory: '4096', sharedfolder: ./, useVagrantCloud: '1', syncType: nfs }
apache:
    install: '1'
    docroot: /vagrant/application/htdocs/public
    servername: www.myservername.com
mysql:
    install: '1'
    root_password: mypwd
    database: mydb
    user: 
    password:
    dump:
php:
    install: '1'
    ppa: php5-5.6
    packages: [php5-cli, php5-intl, php5-mcrypt, php5-curl, php5-gd, php5-mysql, php5-xdebug, php5-dev]
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

2条回答

  • dongyuan4790 dongyuan4790 5年前

    The issue is with

    php:
        install: '1'
        ppa: php5-5.6
        packages: [php5-cli, php5-intl, php5-mcrypt, php5-curl, php5-gd, php5-mysql, php5-xdebug, php5-dev]
    

    so it tries to add ppa:ondrej/php5-5.6 which does not exist anymore, it has been migrated. (see https://launchpad.net/~ondrej/+archive/ubuntu/php)

    so you can change to

    php:
        install: '1'
        ppa: php
    

    so it will add the correct ppa - If you want to work with php 5.6 version make sure to add this version in your packages

    php:
        install: '1'
        ppa: php
        packages: [php5.6-cli, php5.6-intl, php5.6-mcrypt, php5.6-curl, php5.6-gd, php5.6-mysql, php5.6-xdebug, php5.6-dev]
    
    点赞 评论 复制链接分享
  • doutou19761022 doutou19761022 5年前

    The task is looking at a deprecated PPA for php.

    As @Frédéric Henri wrote, it's hard to help you without any details. May be Failed to fetch PPA information (PHP 5.6 / Ubuntu 12.04) helps.

    点赞 评论 复制链接分享

相关推荐