dsp15140275697
2018-03-26 15:18
浏览 218
已采纳

在不更改PHP版本的情况下更新composer

I try to update my composer but i get this error.

 Problem 1
- doctrine/instantiator 1.1.0 requires php ^7.1 -> your PHP version (7.0.10) does not satisfy that requirement.
- doctrine/instantiator 1.1.0 requires php ^7.1 -> your PHP version (7.0.10) does not satisfy that requirement.
- doctrine/instantiator 1.1.0 requires php ^7.1 -> your PHP version (7.0.10) does not satisfy that requirement.
- Installation request for doctrine/instantiator (locked at 1.1.0) -> satisfiable by doctrine/instantiator[1.1.0].

enter image description here

How i can solve this problem without upgrade my version PHP ?

图片转代码服务由CSDN问答提供 功能建议

我尝试更新我的作曲家,但是我收到了这个错误。

 < 代码>问题1 
- doctrine / instantiator 1.1.0需要php ^ 7.1  - &gt; 您的PHP版本(7.0.10)不满足该要求。
- doctrine / instantiator 1.1.0需要php ^ 7.1  - &gt; 您的PHP版本(7.0.10)不满足该要求。
- doctrine / instantiator 1.1.0需要php ^ 7.1  - &gt; 您的PHP版本(7.0.10)不满足该要求。
- doctrine / instantiator的安装请求(锁定在1.1.0) - &gt; 可以通过doctrine / instantiator [1.1.0]来满足。
   
 
 

如果不升级我的PHP版本,我怎么能解决这个问题?

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douxiong2999 2018-03-26 15:23
    已采纳

    If you dont want to update your php version, just use this..

    composer update --ignore-platform-reqs

    or

    composer install --ignore-platform-reqs

    NOTES it is recommended to upgrade your version

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题