2014-10-10 05:56

运行composer install时出现Laravel 4.0.9错误


This never happened in the past for me when deploying Laravel 4. The version is 4.0.9 to be exact. Here is the error when running composer install

root@server1 [/home/testapp/www]# composer install
Warning: This development build of composer is over 30 days old. It is recommended to update it by running "/usr/local/bin/composer self-update" to get the latest version.
Loading composer repositories with package information
Installing dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for laravel/framework 4.0.9 -> satisfiable by laravel/framework[v4.0.9].
    - way/generators dev-master requires illuminate/support ~5.0 -> satisfiable by laravel/framework[5.0.x-dev], illuminate/support[5.0.x-dev].
    - Can only install one of: laravel/framework[v4.0.9, 5.0.x-dev].
    - don't install illuminate/support 5.0.x-dev|don't install laravel/framework v4.0.9
    - Installation request for way/generators dev-master -> satisfiable by way/generators[dev-master].

Does anybody know why this is happening?



    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "require": {
        "laravel/framework": "4.0.9",
        "way/generators": "dev-master",
        "intervention/image": "dev-master",
        "facebook/php-sdk": "dev-master"
    "autoload": {
        "classmap": [
    "scripts": {
        "post-install-cmd": [
            "php artisan optimize"
        "pre-update-cmd": [
            "php artisan clear-compiled"
        "post-update-cmd": [
            "php artisan optimize"
        "post-create-project-cmd": [
            "php artisan key:generate"
    "config": {
        "preferred-install": "dist"
    "minimum-stability": "dev"
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答


  • dpfw3607 dpfw3607 7年前

    You are trying to install dev-master version of way/generators and this dev-master requires illuminate support of version 5.0 where as you are installing laravel 4.0.9 that is why that error is coming up

    please replace "way/generators": "dev-master" with this "way/generators": "2.6.1"

    And you will just be fine.

    Have fun coding ;)

    点赞 评论 复制链接分享
  • dongshicuo4844 dongshicuo4844 7年前

    You could change:

    "way/generators": "dev-master",


    "way/generators": "~2.0",

    without adding exact version number. Now it's 2.6.1 but it could go to 2.6.2 and you will be getting old version if you set here manually number.

    The whole thing happened because you used as version dev-master. And probably dev-master changed from version 2 to 3 and version 3 requires Laravel 5.

    点赞 评论 复制链接分享