dpzff20644
2018-08-10 12:44
浏览 186
已采纳

我的PHP页面引用错误:缺少控制器

I´m new in PHP and creating dynamic webpages and after I installed Apache and my PHP IDE(codelobster) I face a serious problem.I really don´t know what I´m doing wrong but when I create new PHP project and I try to open it via my browser through localhost/...it always return me back a error page with this description:

Error:Missing controller Cake\Routing\Exception\MissingControllerException

My php file is called oneironaut.php so it gives me also: Oneironaut.phpController could not be found.

In the case you tried to access a plugin controller make sure you added it to your composer file or you use the autoload option for the plugin.

Error: Create the class Oneironaut.phpController below in file: src\Controller\Oneironaut.phpController.php

I tried to create different projects like with different names and there was always this bug diference only with name of my .php webpage.So I think this must be some system error and something in my xampp/php or Apache settings must change.Maybe there could be some connection with my unfunctional debugger , I tried to download Xdebug from https://xdebug.org/wizard.php and even though I follow instructions on this website and another websites too I can´t successfully get xdebug extensions into my computer.So in this some help will be highly appreciated too.

So give me someone please help what to do with these problems? Thank You so much.

图片转代码服务由CSDN问答提供 功能建议

我是PHP新手并创建动态网页,在我安装了Apache和我的PHP IDE(代码浏览器)后,我面对 一个严重的问题。我真的不知道我做错了什么但是当我创建新的PHP项目并尝试通过我的浏览器通过localhost / ...打开它时,它总是返回一个错误页面,其中包含以下描述:

错误:缺少控制器 Cake \ Routing \ Exception \ MissingControllerException

我的php文件是 称为oneironaut.php所以它也给了我: 无法找到 Oneironaut.phpController。

如果您尝试访问插件控制器,请确保将其添加到您的编辑器文件或 你使用插件的自动加载选项。

错误:在文件中创建下面的类Oneironaut.phpController: src \ Controller \ Oneironaut.phpController.php

我试图用不同的名字创建不同的项目,并且有一个 这个bug只与我的.php网页的名称不同。所以我认为这肯定是一些系统错误,我的xampp / php或Apache设置中的某些东西必须改变。也许可能与我的无功能调试器有一些联系,我试着下载 来自 https://xdebug.org/wizard.php 的Xdebug,即使我按照本网站上的说明操作 另外一些网站我也无法成功将xdebug扩展到我的电脑中。所以在这方面也会受到一些帮助。

请给我一个人请帮忙解决这些问题 ? 非常感谢你。

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douwo1862 2018-08-10 12:55
    已采纳

    This seems to be happening because the server is loading files in "case-sensitive" mode.

    You call your PHP file "oneironaut.php", however, the page is looking for "Oneironaut.php"

    A similar question has been answered here, please try: Missing Controller Error on remote server using Beta 3

    已采纳该答案
    打赏 评论

相关推荐 更多相似问题