duanmei1350
2015-05-11 13:02 阅读 39
已采纳

Travis-CI无法安装composer deps

Travis-CI start to fail on installing composer deps with next error:

[InvalidArgumentException]                                      
Package ext-ssh2-0.12.0.0 must have a source or dist specified  

https://travis-ci.org/deployphp/deployer/jobs/62059967

Here is composer.json. Locally everything good.

Why Travis-CI fails?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

1条回答 默认 最新

  • 已采纳
    drdawt9210 drdawt9210 2015-05-11 14:00

    Composer is unable to install php extensions yet.

    It looks like you need to provide source for "ext-ssh2", see this issue.

    {
        "repositories":[
            {
                "type":"package",
                "package": {
                    "name":"bower-asset/seiyria-bootstrap-slider",
                    "version":"3.1.0",
                    "dist": {
                        "url": "https://github.com/seiyria/bootstrap-slider/archive/3.1.0.zip",
                        "type": "zip"
                    }
                }
            }
        ]
    }
    
    点赞 评论 复制链接分享

相关推荐