Composer需要ext-redis

I'm trying to set phpredis extension as a requirement for my application. Here is my composer.json:

"ext-redis": ">=2.2.7"

A've also tried these options: "^2.2.7", 2.2.7@dev

But all the time I'm getting the error below:

  Problem 1
    - The requested PHP extension ext-redis >=2.2.7 has the wrong version (2.2.8-devphp7) installed. Install or enable PHP's redis extension.

hy my requirement of >=2.2.7 doesn't stack with an actual version 2.2.8-devphp7 which seems to fit into this version constraint?

php
douji6199
douji6199 我也是这样做的:)
4 年多之前 回复
dongshanyan0322
dongshanyan0322 我提出了一个问题。
4 年多之前 回复
doubinei1457
doubinei1457 我甚至尝试了明确的2.2.8-devphp7和composer失败的“无效的版本字符串”。它非常指向作曲家的问题。
4 年多之前 回复
douchun1961
douchun1961 这是我的问题中的错字。不行。
4 年多之前 回复
duanbi7204
duanbi7204 尝试^2.2.7而不是^2.27。
4 年多之前 回复

1个回答



版本 2.2.8-devphp7 </ code>只是不支持并解析为0 :</ p>


我们根本无法解析 它。 这意味着安装的版本最终无法识别,因此默认为0 </ p>
</ blockquote>

并且永远不会支持:</ p>

展开原文

原文

The version 2.2.8-devphp7 is simply not supported and resolves to 0:

We simply cannot parse it. This means that the installed version ends up being unrecognized, and thus it defaults to 0

and will never be supported:

You have to treat that version as a 0 and allow it by the discouraged * constraint.


Update: It is now supported since composer-1.1.1

dtcuv8044
dtcuv8044 谢谢,我更新了答案。
4 年多之前 回复
dstbp22002
dstbp22002 似乎问题已得到解决,2.2.8-devphp7现在被认为是2.2.8
4 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐