c语言控制台输出中文乱码问题

c语言中使用printf函数输出中文出现乱码,有什么解决办法吗,我以前在网上看到有在命令行
直接更改格式编码的,不过现在忘了,找不到了,有大神能解决吗,就是有没有像
gcc coding=utf-8 xx.c这种类型的直接修改编码。

6个回答

在保证源码的文件编码格式是UTF-8的情况下可以用
gcc main.c -lm -o abc -finput-charset=UTF-8 -fexec-charset=UTF-8

littlely_ll
littlely_ll 后面应该是 -fexec-charset=GBK就对了
2 年多之前 回复
littlely_ll
littlely_ll 源文件编码是utf-8,但是这种方法还是改不了乱码问题
2 年多之前 回复

中文乱码是个老问题了,涉及乱码的问题无非是编码不统一造成的;

涉及编码的地方常见有:

  1. 源文件本身编码

  2. 编译器读取源文件编码

  3. 数据编码(数据库,IO文件等)

  4. 执行输出编码

知道乱码的原因有利于解决乱码问题,这些原因在哪个IDE都是通用的

关于codeblock这款IDE,这里就不说数据库那些编码了,一般写大点的C/C++项目也不会用这种开源免费的工具;

第一步:解决文件本身乱码

如果源码是用codeblock编写的,打开Setting->Editor->General Setting->Ecoding Setting设置如图:

Use encoding when opening files:表示打开文件和第一次保存文件用的编码格式。

As default encoding:表示文件缺省保存和打开编码格式。

如果源文件不是codeblock编写的,就把上面UTF-8换成和原来文件一致的编码;或者用其他工具转成UTF-8(比如notepad)

第二步: 解决编译器读取源文件编码

这里使用GCC编译器,打开Setting->Compiler->Global compiler setting->Compiler setting -> other compiler options;

添加一行:

-finput-charset=UTF-8

如下图

注:这里设置为UTF-8是因为上面第一步设置的源文件编码为UTF-8,如果不是需要两个地方一致;

第三步: 设置执行输出编码

如果机器是windows系统的,需要看看控制台的编码,博主控制台属性如图:

看当前代码页: 936 (ANSI/OEM - 简体中文 GBK)

那么C/C++的执行应该也是要和这里一致的。

还是打开Setting->Compiler->Global compiler setting->Compiler setting -> other compiler options;

添加一行:

-fexec-charset=GBK

如下图:

这样,控制台输出的中文就不会乱码了。

happyzhangdi008
tylerzhangdi 回复qq_41915441: 是编码问题,如果编码没问题,就是编码和解码不统一。
2 年多之前 回复
qq_41915441
qq_41915441 编码不正确有可能是,也有可能没有错,是因为编码不同意,看情况而定
2 年多之前 回复
happyzhangdi008
tylerzhangdi https://blog.csdn.net/fantastic_/article/details/74563680
2 年多之前 回复
  1. 源文件本身编码

  2. 编译器读取源文件编码

  3. 数据编码(数据库,IO文件等)

  4. 执行输出编码

有可能是编码格式不正确

还有一种修改编码的格式:改为gb312

把源码文件编码改成gbk就好了

立即提问
相关内容推荐