qq_43422013
qq_43422013
2021-06-13 16:49
采纳率: 0%
浏览 88

python中装载库时报错importerror:undefined symbol

我在树莓派中安装了Py3.7然后装了PyQt5,当从其中import sip时会报如下错误

>>> from PyQt5 import sip
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: /usr/local/python3/lib/python3.7/site-packages/PyQt5/sip.cpython-37m-arm-linux-gnueabihf.so: undefined symbol: sipSetBool

提示的目录中确实有这个文件,系统里好像还有个自带的Py2.7.9,但是没有安装这个库

请问要如何解决,求求各位大佬了。

  • 点赞
  • 收藏

8条回答 默认 最新

  • technologist_49
    CSDN专家-AlanMax 2021-06-13 16:51
    点赞 评论
  • technologist_49
    CSDN专家-AlanMax 2021-06-13 19:36

    两个方案:1删除libqxcb-egl-integration.so  路径:/usr/lib/arm-linux-gnueabihf/qt5/plugins/xcbglintegrations/ (记得备份)

    2.尝试安装qt https://github.com/tranter/raspberry-pi-qt-builds

    点赞 评论
  • bm1998
    bm1998 2021-06-13 16:59

    解决方法:

    删除PyQt5.11

    pip3 uninstall PyQt5

    重新安装PyQt5.10版本,就没有错误了

    pip3 install "PyQt5<5.11"

    点赞 评论
  • qq_15769939
    小P聊技术 2021-06-14 23:39

    点赞 评论
  • qq_15769939
    小P聊技术 2021-06-14 23:51

    你试着装一下这个:

    pip install PyQt5-sip

    The sip extension module provides support for the PyQt5 package.

    点赞 评论
  • QA_Assistant
    有问必答小助手 2021-06-16 14:25

    您好,我是有问必答小助手,您的问题已经有小伙伴解答了,您看下是否解决,可以追评进行沟通哦~

    如果有您比较满意的答案 / 帮您提供解决思路的答案,可以点击【采纳】按钮,给回答的小伙伴一些鼓励哦~~

    ps: 问答会员年卡【8折】购 ,限时加赠IT实体书,即可 享受50次 有问必答服务,了解详情>>>https://t.csdnimg.cn/RW5m

    点赞 评论
  • csdnssssss
    csdnssssss 2021-06-16 17:08

    你试下pip uninstall PyQt5,然后pip install PyQt5==5.15.2

    点赞 评论
  • m0_59144605
    科道名 2021-06-17 23:23

    可以查阅一下这个https://www.iteye.com/blog/beagoodboy-977453

    有用的话,望采纳,谢谢!

    点赞 评论

相关推荐