dongou3158
2015-04-04 19:50
浏览 103
已采纳

在OpenShift上部署Laravel应用程序

I have git pushed my entire Laravel code base for the application that I had created on my localhost to my OpenShift server. But nothing seems to have come out of it. The webpage is still blank. Can someone tell me what changes to make to the application settings so that it gets deployed properly?

I have deployed it at befikrin-befikrin.rhcloud.com.

Can someone please check and let me know what I might be doing wrong here?

While I was running the project on my localhost I has deployed it using:

php -S localhost:8888 -t public

Do I need to do something on similar lines here?

Update 1

I tried fetching the logs with rhc tail but got the following message:

You can tail this application directly with:
ssh -t <MY_SSH_URL> 'tail */log*/*'
Could not parse PKey: no start line
Usage: rhc tail <application>
Pass '--help' to see the full list of options

Then I tried it with the ssh -t... command suggested above, and this time I got this:

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

Any help at this moment would go a great way as I have been trying to deploy it since yesterday with no avail.

图片转代码服务由CSDN问答提供 功能建议

我已经 git push 编辑了我创建的应用程序的整个Laravel代码库 在我的 localhost 上到我的OpenShift服务器。 但似乎没有任何结果。 该网页仍然是空白的。 有人可以告诉我对应用程序设置进行了哪些更改以便正确部署?

我已将其部署在 befikrin-befikrin.rhcloud.com

有人可以检查并让我知道我在这里做错了什么吗?

当我在 localhost 上运行项目时,我使用以下方式部署了它:

  php -S localhost:8888  -t public 
   
 
 

我是否需要在类似的行上做点什么?

更新1

我尝试使用 rhc tail 获取日志,但收到以下消息:

 你可以尾 此应用程序直接使用:
ssh -t&lt; MY_SSH_URL&gt;  'tail * / log * / *'
无法解析PKey:没有起始行
Usage:rhc tail&lt; application&gt; 
&n'' -  help'查看完整的选项列表
   
 
 

然后我尝试使用上面建议的 ssh -t ... 命令,这次我得到了这个:

 < 代码>权限被拒绝(publickey,gssapi-keyex,gssapi-with-mic)。
   
 
 

此时的任何帮助都会很有用,因为我一直在尝试 从昨天开始部署它没有用。

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douzhaiya3968 2015-04-05 16:18
    已采纳

    The Laravel 5.0 and Laravel 4.2 QuickStarts exist for a reason. I STRONGLY recommend using them as a starting point for your Laravel application on OpenShift unless you're VERY familiar with both Laravel and OpenShift Online.

    Deploy one of the QuickStarts below and port your existing application code over:

    If you run into trouble contact OpenShift via our help site and mention @luciddreamz sent you in the comments.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题