douzhuoxia0587
2015-07-30 08:55
浏览 102
已采纳

elasticsearch版本1.2.1的脚本错误

I am getting this error when i try to run the script.

{"error":"RemoteTransportException[[Fin][inet[/192.168.1.127:9300]][update]]; nested: ElasticsearchIllegalArgumentException[failed to execute script]; nested: ScriptException[scripts of type [inline], operation [update] and lang [groovy] are disabled]; ","status":400}

I find that in the elasticsearch.yml, I have to configure it disable, if I use version 1.4.3 or more, but I am using Elasticsearch Version 1.2.1, where is automatically enabled.

script.disable_dynamic: false

So how can I fix this issue. Does anyone know how to solve this problem?

图片转代码服务由CSDN问答提供 功能建议

我在尝试运行脚本时收到此错误。

   {“error”:“RemoteTransportException [[Fin] [inet [/192.168.1.127:9300]] [update]];嵌套:ElasticsearchIllegalArgumentException [无法执行脚本];嵌套:ScriptException [类型为[inline]的脚本]  ,操作[更新]和lang [groovy]被禁用];“,”状态“:400} 
   
 
 

我在 elasticsearch.yml中找到了 ,我必须配置它禁用,如果我使用的是1.4.3或更高版本,但我使用的是Elasticsearch Version 1.2.1,它会自动启用。

  script.disable_dynamic:false 
   
 
 

那么我该如何解决这个问题呢。 有谁知道如何解决这个问题?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongtuota3633 2015-07-30 09:11
    已采纳

    In ES 1.6, you need to use the following config parameters:

    script.inline: on
    script.indexed: on
    

    Try it out.

    PS: I would not use versions prior to 1.3 anymore. If you can upgrade to 1.6 at a minimum.

    已采纳该答案
    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题