2015-11-08 20:43
浏览 48

Composer / Laravel安装:我的命令行不再理解PATH

running mac Yosemite 10.10.5

A couple of days ago I installed Laravel for the first time. That part went pretty smooth! Once it was time to install composer I was able to find some help here! This command on bash Profile made it work for me: PATH="$PATH:~/.composer/vendor/bin"

Fast-Forward to today when I am attempting to install XAMPP and Bitnami.. The Apache server and all that. So I think I am ready to roll and as I tried to create a project I was told that I did not have the mcrypt file? So down THAT rabbit hole I went. That was a tough one but I managed to get it to work.

Now forgive me but I don't remember what happened next that led me to re-install composer and that turned out to be an other huge issue as it wouldn't allow me to do so.. I would get this message

Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:
The detect_unicode setting must be disabled.
Add the following to the end of your `php.ini`:
    detect_unicode = Off

After doing some research I was able to download Composer again by running this command..

curl -s | php -d detect_unicode=Off

I thought I was on my way.. 2 hours have gone by! Boy was I wrong! :( What once used to work.. composer commands in my terminal.. all of the sudden are not recognized..

Commands like this worked before.. composer create-project laravel/laravel=5.0 TestApp

but now it returns this.. ??+?abelista /Applications/XAMPP/htdocs Question Marks along my machines name..

Nothing with composer runs.. I have tried changing my PATH in my Bash Profile too..



and remember this one below used to work..


From my understanding.. If I can recall correctly.. I think the problem began when I ran homebrew to install mcrypt.. I could be wrong. Does anyone here have the slightest idea what could be my issue?

BTW, according to my command line.. composer is installed..

All settings correct for using Composer

Composer successfully installed to: /Applications/XAMPP/xamppfiles/htdocs/composer.phar
Use it: php composer.phar

Thanks for reading and trying to help me out.

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

1条回答 默认 最新

相关推荐 更多相似问题