doubiantiao4994
doubiantiao4994
2015-10-08 11:10

[composer update => commit => push => pull]后的Laravel错误

已采纳

Well, I added a package, "guzzlehttp/guzzle": "~5.3|~6.0" to be specific, inside my laravel app, and updated(for sending email). Then I committed the changes to the local repo (git), and pushed to the remote repo on Bitbucket. And finally I pulled the changes on my VPS server. It's worth mentioning that I have done this same process a hundred times without any problems whatsoever and I don't have any clue why it's being such a jerk this time :-|

OK, here's the problem: Blank white screen screen and when I do error_reporting(E_ALL); ini_set.... I get this error message:

Warning: require(/home/.../vendor/guzzlehttp/promises/src/functions_include.php): failed to open stream: No such file or directory in /home/.../vendor/composer/autoload_real.php on line 54

Fatal error: require(): Failed opening required '/home/.../vendor/guzzlehttp/promises/src/functions_include.php' (include_path='.:/usr/share/php:/usr/share/pear') in /home/.../vendor/composer/autoload_real.php on line 54

Oh, and by the way, the project is totally working fine on my local machine without any problems.

Thanks a lot, appreciate it :-)

EDIT:

I also tried running these:

  • running composer update
  • deleting vender/ and composer.lock and then running the above command

and they didn't work because I saw the same error during the execution of composer update because it was calling artisan.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

  • douzhongju8780 douzhongju8780 6年前

    Thanks to aldrin27 I solved the error by dumping the autoloads using:

    composer dump-autoload
    

    But then there was this error:

    Trait 'Illuminate\Database\DetectsLostConnections' not found
    

    For some odd reason that file was missing and I had to create it manually to fix the problem.

    点赞 评论 复制链接分享

相关推荐